• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved NGINX 502 bad gateway after activating fail2ban

LaurentR2D2

Regular Pleskian
Plesk Certified Professional
OS‪CentOS Linux 7.4.1708 (Core)‬ProduitPlesk Onyx
Version 17.5.3 Mise à jour n° 23, dernière mise à jour le 2 Oct 2017 03:51

Hello,

I can't activate fail2ban, since I always get a NGINX 502 bad gateway error on my websites when I do it. Should I reinstall it like it was suggested for Debian/Ubuntu systems ? ModSecurity is activated with Atomic Basic ModSecurity, and intermediate settings.

Thank you
 
Hi LaurentR2D2,

did you probably forget to insert "localhost" your server IP's on your server to the whitelist of Fail2Ban?

Should I reinstall it like it was suggested for Debian/Ubuntu systems ?
This is never a bad idea, to solve ( possible ) issues/errors/problems, but from my point of view, you should rather investigate the root cause of your issue, as you might experience the very same issues/errors/problems again afterwards. :(
 
Hi LaurentR2D2,

did you probably forget to insert "localhost" your server IP's on your server to the whitelist of Fail2Ban?


This is never a bad idea, to solve ( possible ) issues/errors/problems, but from my point of view, you should rather investigate the root cause of your issue, as you might experience the very same issues/errors/problems again afterwards. :(

I've added the ip of my server, and the problem is solved. There was 127.0.0.1/8 in the whitelist, but obviously it was not enough. Thank you :)
 
Back
Top