1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

nginx _SERVER["HTTP_HOST"] is incorrect?

Discussion in 'Plesk 11.x for Linux' started by Zanami.RU, Jul 2, 2012.

  1. Zanami.RU

    Zanami.RU New Pleskian

    16
    35%
    Joined:
    Mar 18, 2011
    Messages:
    12
    Likes Received:
    0
    centos 5, plesk 11.0.9, nginx enabled, nothing touched in nginx/apache config

    phpinfo()

    46.8.154.111 is my IP
    I believe _SERVER["HTTP_HOST"] should be whatever.com, the actual host name that set in last_nginx.conf ( proxy_set_header Host $host;).

    Drupal isn't working (it redirects me to MY IP and looking for it's internal urls). Some Wordpress sites do work fine, others do not.

    Had to disable nginx for now.
     
  2. Zanami.RU

    Zanami.RU New Pleskian

    16
    35%
    Joined:
    Mar 18, 2011
    Messages:
    12
    Likes Received:
    0
    Oops, never mind, fixed that — it was a leftover configuration file from custom plesk10/nginx combination (extra apache mod_rpaf2.conf file in /etc/httpd/conf.d, fixed by removing it).
     
Loading...