• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

nginx error

Tsi-Shawn

Basic Pleskian
Restarting nginx I get the error:

nginx: [warn] conflicting server name "www.strategicmineplanning.com" on 206.248.173.164:80, ignored
Starting nginx: nginx: [warn] conflicting server name "www.strategicmineplanning.com" on 206.248.173.164:80, ignored

www.strategicmineplanning.com is not in the control panel and is not located in /var/www/vosts (because it is a forward it does not show up in vhosts)

If you go to the URL it forwards you to a site. This site is in the control panel and also has another forward in the control panel pointing to it: www.strategicmineplanning.ca

If I try to add www.strategicmineplanning.com to the control panel it fails with an error stating that the site is already there.

When I look for the site in the cli I get the following back:

[root@webhost1 vhosts]# locate strategicmineplanning.com
/etc/httpd/conf/plesk.conf.d/forwarding/strategicmineplanning.com_httpd.conf
/etc/httpd/conf/plesk.conf.d/forwarding/strategicmineplanning.com_httpd.conf.bak
/etc/httpd/conf/plesk.conf.d/forwarding/www.strategicmineplanning.com_httpd.conf
/etc/httpd/conf/plesk.conf.d/webmails/roundcube/strategicmineplanning.com_webmail.conf
/etc/httpd/conf/plesk.conf.d/webmails/roundcube/www.strategicmineplanning.com_webmail.conf
/etc/nginx/plesk.conf.d/forwarding/strategicmineplanning.com_nginx.conf
/etc/nginx/plesk.conf.d/forwarding/strategicmineplanning.com_nginx.conf.bak
/etc/nginx/plesk.conf.d/forwarding/www.strategicmineplanning.com_nginx.conf
/etc/nginx/plesk.conf.d/webmails/strategicmineplanning.com_webmail.conf
/etc/nginx/plesk.conf.d/webmails/www.strategicmineplanning.com_webmail.conf
/var/named/chroot/var/strategicmineplanning.com
/var/qmail/mailnames/strategicmineplanning.com
/var/spool/postfix/private/plesk-strategicmineplanning.com-206.248.173.164-

When I ping/host/dig the site it all points back to the server. So it is hosted on the server but it is not viewable in the control panel. Any thoughts?
 
Igor,

That fixed the nginx error but when trying to add the domain through the control panel:


Domain name *
www. This domain name already exists.
 
Maybe additionally you need to remove other files with www and check corresponding orphaned records in psa database.
 
Run

# plesk db

and use SQL queries for searching extra records in tables about this domain. Contact Parallels Support Team if you are not familiar with SQL.
 
Back
Top