• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved Onyx Upgrade error

wmmk

New Pleskian
Hi all,

i've got a mysterious error while updating my plesk installation to the latest onyx version. During upgrading i get the following error:

Exception: Failed to solve dependencies:
php70w-common conflicts with php-common-5.4.16-42.el7.x86_64

The full log says:

Installation started in background
Loaded plugins: fastestmirror, langpacks
NGINX-thirdparty | 2.9 kB 00:00
PHP52_17 | 2.9 kB 00:00
PHP53_17 | 2.9 kB 00:00
PHP_5_2-thirdparty | 2.9 kB 00:00
PHP_5_3-thirdparty | 2.9 kB 00:00
PHP_5_4-thirdparty | 2.9 kB 00:00
PHP_5_5-thirdparty | 2.9 kB 00:00
PHP_5_6-thirdparty | 2.9 kB 00:00
PHP_7_0-thirdparty | 2.9 kB 00:00
PLESK_17_0_17-dist | 2.9 kB 00:00
PLESK_17_0_17-extras | 2.9 kB 00:00
PLESK_17_0_17-thirdparty | 2.9 kB 00:00
PLESK_17_NGINX | 2.9 kB 00:00
PLESK_17_PHP54 | 2.9 kB 00:00
PLESK_17_PHP55 | 2.9 kB 00:00
PLESK_17_PHP56 | 2.9 kB 00:00
PLESK_17_PHP70 | 2.9 kB 00:00
Loading mirror speeds from cached hostfile
* base: mirror.cuegee.de
* epel: mirror.netcologne.de
* extras: ftp.plusline.de
* updates: mirror.netcologne.de
* webtatic: uk.repo.webtatic.com
No package matched to remove: php70w-common
Attempt to remove 'php70w-common' to resolve conflict has failed
Attempt to remove 'php-common' to resolve conflict has succeeded
No package matched to remove: php70w-common
Attempt to remove 'php70w-common' to resolve conflict has failed
Attempt to remove 'php-common' to resolve conflict has succeeded
No package matched to remove: php70w-common
Attempt to remove 'php70w-common' to resolve conflict has failed
Attempt to remove 'php-common' to resolve conflict has succeeded
No package matched to remove: php70w-common
Attempt to remove 'php70w-common' to resolve conflict has failed
Attempt to remove 'php-common' to resolve conflict has succeeded
No package matched to remove: php70w-common
Attempt to remove 'php70w-common' to resolve conflict has failed
Attempt to remove 'php-common' to resolve conflict has succeeded
Exception: Failed to solve dependencies:
php70w-common conflicts with php-common-5.4.16-42.el7.x86_64
Error: Das Dienstprogramm Yum konnte nicht die erforderlichen Pakete installieren.
Achtung! Ihre Software ist vielleicht nicht betriebsbereit.
Bitte kontaktieren Sie den technischen Produktsupport.

My linux experience is not sufficient enough to solve the problem by myself. Tried already to uninstall the package but that didn't help.

I'm thankful for any help here in this forum.
 
I would not recommend using webtatic repository. As far as I remember it is not supported by Plesk officially.
Try to disable this repository.
 
Back
Top