1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

open_basedir restriction in effect but file is in the correct dir

Discussion in 'Plesk 11.x for Windows' started by CFI, Sep 22, 2012.

  1. CFI

    CFI New Pleskian

    15
    85%
    Joined:
    Apr 6, 2011
    Messages:
    9
    Likes Received:
    0
    I am trying to move some sites to a new server and I am getting the following Error:

    But the configuration.php file is in C:\Inetpub\vhosts\domain.com\domains\domain.com\www\!

    I am nearly getting cracy here as this makes absolutely no sense to me.
    I can even set the open_basedir value to none and still get the same error.
    Same also for using PHP 5.2 or 5.3.

    The only thing which got me a little bit further was setting a dirname(__FILE__) in front of the call in index.php on line 18, but this is no solution as I can't alter all file references in the whole CMS. Because of this I also tried to add the www folder to the include path without any luck.

    Everything was working fine on the old machine (running CentOS).

    UPDATE: Just found out, that the Working Directory is wrong. It is the directory of the php executable not the main script or DOCROOT, but I have no idea how to fix that...
    UPDATE2: It works when using CGI instead of FastCGI.
     
    Last edited: Sep 22, 2012
  2. chris.dempsey

    chris.dempsey New Pleskian

    13
    35%
    Joined:
    Jun 19, 2011
    Messages:
    13
    Likes Received:
    0
    Did you find a way to resolve this issue while running PHP via FastCGI? I have the same issue following update of Plesk Panel 9.5.4 to 11.0.9 plus installation of PHP 5.3.

    Websites that were working fine on PHP 5.2.17 FastCGI now fail with error: open_basedir restriction in effect when require_once('file.inc') is called.

    Any idea how to resolve?
     
  3. CFI

    CFI New Pleskian

    15
    85%
    Joined:
    Apr 6, 2011
    Messages:
    9
    Likes Received:
    0
    No, I am running my pages as CGI at the moment and will switch to ASP.NET soon so I am not activly searching a solution anymore...
     
  4. chris.dempsey

    chris.dempsey New Pleskian

    13
    35%
    Joined:
    Jun 19, 2011
    Messages:
    13
    Likes Received:
    0
    Appreciate the swift response. I started a new thread so maybe someone else can help.
     
Loading...