1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

OScommerce issues

Discussion in 'Plesk for Windows - 8.x and Older' started by dwdietz, Jan 8, 2005.

  1. dwdietz

    dwdietz Guest

    0
     
    Ok i have spent hours, days, weeks here.. I am almost sure it is some sort of permissions but cant find it.

    Does anyone here have 2003 server with plesk 7.0 and have oscommerce successfully running? My problems is the plugnpay payment module (which is identical to authorize.net) using curl.. I could not get the compiled version to work so i used the non compiled config and put curl.exe in c:/curl/curl.exe

    Here is my dilemna.. oscommerce on the admin/tools/server_info.php is just blank.. php just dies and never returns any info..

    Well not so bad except that when in oscommerce and checkout when you get to confirm order, it does the same thing.. returns a blank page, (no error)

    well i checked curl.. i ran the curl command for plugnapy from a dos prompt and perfect.. works just fine and gives me my return info for approval or failure.

    So within php and oscommerce here is what i am finding. When you confirm order, it does contact plugnpay (i see the traffic leaving and going to pnp on my firewall), it gets a return from plugnpay, but dos curl can not seem to return the info back to php to display on the web page. I can tell i got a return from the plugnpay-debug.txt file that plugnpay uses to test.

    oh yeah i did have to assign iusr_xxx execute rights to cmd before i even got this far.. I also might mention that if i run test code in php to run just exec {"curl -V"}; i get the return just fine into php and it displays the information that curl returns on the web page.. but with curl and oscommerce it is sending multiple arguments with curl (which may be an issue with windows not sure)


    PLEASE HELP

    :mad:


    Doug
     
Loading...