1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

OTRS and Plesk: Webserver does not start with vhosts.conf

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by MarcoJ, Dec 14, 2011.

  1. MarcoJ

    MarcoJ New Pleskian

    16
    60%
    Joined:
    Nov 7, 2010
    Messages:
    16
    Likes Received:
    0
    Hi,

    i did a manual install of OTRS on a subdomain in my Plesk 10. I've got stuck at the point of configuring Apache for this subdomain, as the OTRS configuration file put in as vhosts.conf will cause the Plesk-Apache not to start anymore.

    I would be happy if anybody has an idea on this, i'll attach the vhosts.conf below.

    Thanks,
    Marco

    # --
    # added for OTRS (http://otrs.org/)
    # $Id: apache2-httpd.include.conf,v 1.18.2.3 2011/04/19 22:09:24 en Exp $
    # --

    # agent, admin and customer frontend
    ScriptAlias /otrs/ "/var/www/vhosts/mydomain.de/support/opt/otrs/bin/cgi-bin/"
    Alias /otrs-web/ "/var/www/vhosts/mydomain.de/support/opt/otrs/var/httpd/htdocs/"

    # activate this if you are using an Oracle database
    #SetEnv ORACLE_HOME /path/to/your/oracle/
    #SetEnv ORACLE_SID YOUR_SID
    #SetEnv NLS_LANG AMERICAN_AMERICA.UTF8
    #SetEnv NLS_DATE_FORMAT 'YYYY-MM-DD HH24:MI:SS'

    # if mod_perl is used
    <IfModule mod_perl.c>

    # load all otrs modules
    Perlrequire /var/www/vhosts/mydomain.de/support/opt/otrs/scripts/apache2-perl-startup.pl

    # Apache::Reload - Reload Perl Modules when Changed on Disk
    PerlModule Apache2::Reload
    PerlInitHandler Apache2::Reload
    PerlModule Apache2::RequestRec

    # set mod_perl2 options
    <Location /otrs>
    # ErrorDocument 403 /otrs/customer.pl
    ErrorDocument 403 /otrs/index.pl
    SetHandler perl-script
    PerlResponseHandler ModPerl::Registry
    Options +ExecCGI
    PerlOptions +ParseHeaders
    PerlOptions +SetupEnv
    Order allow,deny
    Allow from all
    </Location>

    </IfModule>

    # directory settings
    <Directory "/var/www/vhosts/mydomain.de/support/opt/otrs/bin/cgi-bin/">
    AllowOverride None
    Options +ExecCGI -Includes
    Order allow,deny
    Allow from all
    </Directory>
    <Directory "/var/www/vhosts/mydomain.de/support/opt/otrs/var/httpd/htdocs/">
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    <IfModule mod_headers.c>
    <Directory "/var/www/vhosts/mydomain.de/support/opt/otrs/var/httpd/htdocs/skins/*/*/css-cache">
    <FilesMatch "\.(css|CSS)$">
    Header set Cache-Control "max-age=2592000 must-revalidate"
    </FilesMatch>
    </Directory>

    <Directory "/var/www/vhosts/mydomain.de/support/opt/otrs/var/httpd/htdocs/js/js-cache">
    <FilesMatch "\.(js|JS)$">
    Header set Cache-Control "max-age=2592000 must-revalidate"
    </FilesMatch>
    </Directory>
    </IfModule>

    # MaxRequestsPerChild (so no apache child will be to big!)
     
    Last edited: Dec 14, 2011
  2. Faris Raouf

    Faris Raouf Silver Pleskian Plesk Guru

    31
    30%
    Joined:
    Mar 15, 2009
    Messages:
    667
    Likes Received:
    17
    Take a look in the apache log to see what, exactly is causing the problem. It should specify the exact nature of the problem if we are lucky.
     
Loading...