• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

PCI Compliance Issues

D

davidthurston

Guest
Hi, apologies if any of this has been posted before. I searched, but couldn't find anthing that applied to me.
I have the following Failures from Security Metrics.

VPS from Webfusion, Running Ubuntu 10, and Plesk 10.4.4

----------------------

Description: possible format string vulnerability in Courier IMAP Severity: Potential Problem CVE: CVE-2004-0777 Impact: A remote attacker could execute arbitrary commands. Resolution [http://www.courier-mta.org/download.php #imap] Upgrade to Courier IMAP 3.0.4 or higher, or set DEBUG_LOGIN equal to the default value of 0 in the IMAP configuration file, which is typically located in /usr/lib/courier-imap/etc/imapd. Vulnerability Details: Service: imap

I checked the version on plesk, and it is 3.08. Checked /etc/courier-imap/imapd and its got DEBUG=0

-----------------------------------------

Description: possible vulnerability in ProFTP 1.3.3e Severity: Area of Concern CVE: CVE-2011-4130 Impact: Attackers exploiting these vulnerabilities may be able to execute arbitrary commands, perhaps with root privileges, gain unauthorized access, or disrupt service on a target system. Resolution Upgrade [http://www.proftpd.org] ProFTPD to version [http://www.proftpd.org/docs/RELEASE_NOT ES-1.3.3g] 1.3.3g (stable) or greater.

We're running version 1.3.3e

--------------------------------------------
 
I think i have solved issue 1
I sent SM the results of
dpkg --list | grep courier-imap
and grep DEBUG_LOGIN /etc/courier-imap/imapd

That should hopefully be good enough for them.

Any ideas on the second issue about Proftp?
 
Back
Top