1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php as cgi/fastgi safemode

Discussion in 'Plesk 9.x for Linux Suggestions and Feedback' started by Rustam Khamidov, Mar 23, 2009.

  1. Rustam Khamidov

    Rustam Khamidov Guest

    0
     
    When php run as CGI/FastCGI mode, the safe mode is always turned ON.
    Thus, checkbox safemode does not work.
    This is a bug or a feature?

    P.S. sysinfo

    OS: Centos release 5.2 (Final)
    x86_64
    Linux xxxxx 2.6.18-92.1.13.el5 #1 SMP Wed Sep 24 19:32:05 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

    Plesk: 9.0.1
    psa-9.0.1-cos5.build90090127.18
     
    Last edited by a moderator: Mar 23, 2009
  2. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    i do not know centos, but on debian there are 2 different php.ini files

    one for apache and one for cli, cgi/fast-cgi uses the cli one ...

    and plesk does not modify the cli one ...
     
  3. Rustam Khamidov

    Rustam Khamidov Guest

    0
     
    I am not talking about the php.ini file!
    It is about generating a file httpdocs.include (full filename on my system like /var/www/vhosts/domain.name/conf/httpdocs.include).
    In this file in case of php as cgi / fastgi, regardless of safemode checkbox, contain follow line
    php_admin_flag safe_mode on
    Which should vary with changes in safemode.
     
  4. jfine

    jfine Guest

    0
     
    I'm seeing the same issue on Plesk 9.3 running on Ubuntu 8.04 Server LTS. When you choose FastCGI the safe_mode box is ignored so the global safe_mode setting is used. I'd prefer to keep the global setting On so my current fix is to override with a vhost.conf.
     
Loading...