1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP: Not being recognized as PHP in served sites

Discussion in 'Plesk for Linux - 8.x and Older' started by sritchie, May 31, 2005.

  1. sritchie

    sritchie Guest

    Running Plesk 7.5.3 Reloaded. I have a basic domain within the server that needs PHP support. Turned PHP on via the Control Panel. The PHP Engine shows as "on" in the specific vhosts.conf file for the domain. Yet, PHP files still try to render as plain text docs when called via URL.

    Is there something else that controls whether or not a given domain on a Plesk install can server up PHP?

    Thanks in advance,
  2. kake26

    kake26 Guest

    I was just trolling the forums and saw this. If the server spits PHP out as text this means there is a problem with the apache config. Here is what you need to check and try.

    First thing to do is get root access to the box. once you're root try

    Next you want to use pico,nano or vi to open the httpd.conf itself to look if PHP is properly setup. Look for the lines listed below in your httpd.conf(/usr/local/psa/apache/conf/httpd.conf)

    If you don't see those in there then just toss them in and save httpd.conf, then restart apache and do that cat and grep thing I listed above if then see the line as mentioned above then good try the site again and it should work. If it still doesn't work I suggest you login into plesk goto that domains setup and disable PHP support, save it and go back and renable it. Also restart apache after that and try the PHP again, see if it works. Well that pretty much covers anything that could be causing it. Let me know how it works out I promise to check this thread periodically over the next few days.