1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php problems

Discussion in 'Plesk for Linux - 8.x and Older' started by CollNet, Oct 1, 2005.

  1. CollNet

    CollNet Guest

    0
     
    I must be an idiot because I can't figure this out. I've found a few other threads where people have had the same problem but not one that I found posted the resolution.

    I have a domain & a subdomain set up that needs to run with php. The domain does have php enabled.

    The domain index.php page comes up blank and the subdomain page shows the php code instead of the execution. No errors for either.

    I ran a phpinfo for the main domain and it excuted just fine so that I got the correct exectution path

    when I run the phpinfo on the subdamon I get a download window pop up, but I found info for the subdomains on another post .. so for the subdomain I have the path set as

    /home/httpd/vhosts/domanname.com/subdomains/subname/httpdocs/

    I have no idea where else to check for the answer to this problem, I've been through manuals and posts for days now.

    Can anyone at least point me in some direction?
    Thanks!
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    This may seem rather a basic question, but when you setup the subdomain, did you put a checkmark in the 'PHP Support' option ? (on the screen where you define the subdomain)

    I have a number of subdomains defined on my test server and did not have to do anything special (other than put the checkmark) to get an index.php file to work.

    I still have a couple of subdomains from helping another forum user, you can see the index.php working at:

    http://cars.james-yee.net
    http://cars1.james-yee.net

    These are normal Plesk created subdomains.
     
  3. CollNet

    CollNet Guest

    0
     
    Thank you for replying. It's hard for me to believe that I didn't check the enable php box when I created the subdomain but I couldnt find anywhere in the admin panel to verify it. So I just deleted the subdomain and recreated/reloaded it and it's fine now.

    My other problem has to do with php.ini settings so I got those fixed too. Hopefully this will take care of the php issues.

    Now I just have to figure everything else out :eek:
     
Loading...