The new Plesk 8.4 has php 5.1.6-3.7.fc6 and the PCI Compliance testing company failed me on the compliance test because they say that PHP needs to be updated to V5.2.6 or later. See below: Security Vulnerabilities Protocol Port Program Risk TCP 8443 https-alt 8 Synopsis : The remote web server uses a version of PHP that is affected by multiple flaws. Description : According to its banner, the version of PHP installed on the remote host is older than 5.2.6. Such versions may be affected by the following issues : - A stack buffer overflow in FastCGI SAPI. - An integer overflow in printf(). - An as-yet unspecified security issue tracked by CVE-2008-0599. - A safe_mode bypass in cURL. - Incomplete handling of multibyte chars inside escapeshellcmd(). - Issues in the bundled PCRE fixed by version 7.6. See also : http://archives.neohapsis.com/archives/f ulldisclosure/2008-05/0103.html http://archives.neohapsis.com/archives/f ulldisclosure/2008-05/0107.html http://www.php.net/releases/5_2_6.php Solution: Upgrade to PHP version 5.2.6 or later. Risk Factor: High / CVSS Base Score : 7.5 (CVSS2#AV:N/AC:L/Au:N/C/I/A) CVE : CVE-2008-0599 BID : 29009 Other references : Secunia:30048 I have downloaded php-5.2.6.tar.gz So I guess I need help on whether installing this will cause a problem with the newly installed Plesk 8.4 (UNIX) and where & how to install it. Thank you in advance.