1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

phpmyadmin on-the-fly export

Discussion in 'Plesk for Linux - 8.x and Older' started by nars, Jul 27, 2007.

  1. nars

    nars Guest

    0
     
    Hi,

    Since I updated to Plesk 8.1.1 (and still same with 8.2) I noticed a difference in phpMyAdmin export behavior, on versions prior to 8.1.1 when we started to export a DB on phpMyAdmin it would immediately start to download the file, even when using gzip compression, it would compress it on-the-fly, now since 8.1.1 I notice we click to start export and it takes some time (depending on DB size) to start download and I can see httpsd proccess memory usage increasing, I guess it is buffering whole DB on memory... also very large DB's seems even impossible to backup now, browser will be waiting server reply forever (even after we can see httpsd activity ended on server) I guess due to memory exhausting or something... :( is there any way to fix this so that it can work as it did on 8.0.x?

    I already checked /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin/libraries/config.default.php and I have $cfg['CompressOnFly'] = TRUE;

    Also please note that this is not happening only when exporting to compressed file, when exporting plain uncompressed file I get exactly same issue...

    Any ideas? Anyone having same issue?

    Regards

    PS. I'm able to reproduce the issue on two machines, one prodution server with 8.1.1 and a test system with 8.2, both with Centos 4.5.
     
  2. nars

    nars Guest

    0
     
    Just to add, I even tried to set $cfg['MemoryLimit'] = 8*1024*1024; on config.default.php and memory_limit = 8M on /usr/local/psa/conf/php.ini, but still if I export eg. a 50MB DB it takes some time to start download and I can see httpsd using a lot of system memory... I cannot understand... how can it allocate more memory than memory_limit php setting?? I'm starting to bang my head on table and thinking it would be beter to stay with 8.0.1 :(

    Edit: As temporary solution I did installed phpMyAdmin running from main httpd and it is working perfectly (as the one integrated with Plesk did on past) and I'm telling my clients to use it instead of the one integrated in Plesk. :)
     
Loading...