• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Plesk Apache server failing to start after update to 10.4.4

E

ElderBrE

Guest
I am having this error when trying to start the Web Server (Apache) service:

Error: Unable to make action: Unable to manage service by apache_control_adapter: Service /etc/init.d/apache2 failed to start
Service /etc/init.d/apache2 failed to start ('--start', 'web')

When trying to rebuild config files:

username:/# /usr/local/psa/admin/sbin/websrvmng -a -v
WARNING: You are using obsolete option, use corresponding option of httpdmng.
websrvmng: /opt/psa/admin/bin/httpdmng execution failed:
PleskUtilException: '/opt/psa/admin/bin/apache-config' '-t' failed with code .

stdout:


stderr:
apache2: Syntax error on line 227 of /etc/apache2/apache2.conf: Syntax error on line 6 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 10 of /opt/psa/admin/conf/generated/13401509110.67432500_horde.include: Syntax error on line 5 of /opt/psa/admin/conf/webmail_horde_bootstrap.conf: Could not open configuration file /opt/psa/admin/conf/generated/13396983610.98222900_festhome_com_webmail.include: No such file or directory

file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 71
code: 0
trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(4, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(4, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('f7a99003476cdcb...', Array, Object(Service_Agent_Log))
#3 /opt/psa/admin/plib/Template/Writer/Apache.php(58): Service_Agent->commit()
#4 /opt/psa/admin/plib/Template/Configuration/Applier.php(196): Template_Writer_Apache->test()
#5 /opt/psa/admin/plib/Template/Configuration/Applier.php(117): Template_Configuration_Applier->_applyConfigurationsToServiceNode(1, Array)
#6 /opt/psa/admin/plib/WebServerManager/Adapter/Apache.php(125): Template_Configuration_Applier->applyConfiguration(true)
#7 /opt/psa/admin/plib/WebServerManager/Adapter/Apache.php(313): WebServerManager_Adapter_Apache->sync()
#8 /opt/psa/admin/plib/WebServerManager.php(199): WebServerManager_Adapter_Apache->reconfigureServer(Object(Db_Table_Row_ServiceNode))
#9 /opt/psa/admin/plib/api-common/Httpdmng.php(123): WebServerManager->reconfServer()
#10 /opt/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#11 {main}

2012-06-20T01:08:32+01:00 ERR (3): Apache config (13401509110.67432500) generation failed: apache2: Syntax error on line 227 of /etc/apache2/apache2.conf: Syntax error on line 6 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 10 of /opt/psa/admin/conf/generated/13401509110.67432500_horde.include: Syntax error on line 5 of /opt/psa/admin/conf/webmail_horde_bootstrap.conf: Could not open configuration file /opt/psa/admin/conf/generated/13396983610.98222900_festhome_com_webmail.include: No such file or directory

apache2: Syntax error on line 227 of /etc/apache2/apache2.conf: Syntax error on line 6 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 10 of /opt/psa/admin/conf/generated/13401509110.67432500_horde.include: Syntax error on line 5 of /opt/psa/admin/conf/webmail_horde_bootstrap.conf: Could not open configuration file /opt/psa/admin/conf/generated/13396983610.98222900_festhome_com_webmail.include: No such file or directory

PleskUtilException: /opt/psa/admin/bin/httpdmng '--reconfigure-server' '-no-restart' failed with message: Empty error message from utility.
file: /opt/psa/admin/plib/common_func.php3
line: 1065
code: 0
trace: #0 /opt/psa/admin/plib/common_func.php3(983): util_exec('httpdmng', Array, Array, 'msg', NULL)
#1 /opt/psa/admin/plib/Os.php(17): smart_exec('httpdmng', Array, Array, 'msg')
#2 /opt/psa/admin/plib/Os.php(28): Os::exec('httpdmng', Array, 'msg')
#3 /opt/psa/admin/plib/api-common/Httpdmng.php(89): Os::execEx('httpdmng', Array)
#4 /opt/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#5 {main}

Execution failed.
Command: httpdmng
Arguments: Array
(
[0] => --reconfigure-server
[1] => -no-restart
)

Details: Empty error message from utility.
websrvmng: /opt/psa/admin/bin/httpdmng execution failed:
PleskUtilException: '/opt/psa/admin/bin/apache-config' '-t' failed with code .

stdout:


stderr:
apache2: Syntax error on line 227 of /etc/apache2/apache2.conf: Syntax error on line 6 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 10 of /opt/psa/admin/conf/generated/13401509110.67432500_horde.include: Syntax error on line 5 of /opt/psa/admin/conf/webmail_horde_bootstrap.conf: Could not open configuration file /opt/psa/admin/conf/generated/13396983610.98222900_festhome_com_webmail.include: No such file or directory

file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 71
code: 0
trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(4, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(4, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('f7a99003476cdcb...', Array, Object(Service_Agent_Log))
#3 /opt/psa/admin/plib/Template/Writer/Apache.php(58): Service_Agent->commit()
#4 /opt/psa/admin/plib/Template/Configuration/Applier.php(196): Template_Writer_Apache->test()
#5 /opt/psa/admin/plib/Template/Configuration/Applier.php(117): Template_Configuration_Applier->_applyConfigurationsToServiceNode(1, Array)
#6 /opt/psa/admin/plib/WebServerManager/Adapter/Apache.php(125): Template_Configuration_Applier->applyConfiguration(true)
#7 /opt/psa/admin/plib/WebServerManager/Adapter/Apache.php(313): WebServerManager_Adapter_Apache->sync()
#8 /opt/psa/admin/plib/WebServerManager.php(199): WebServerManager_Adapter_Apache->reconfigureServer(Object(Db_Table_Row_ServiceNode))
#9 /opt/psa/admin/plib/api-common/Httpdmng.php(123): WebServerManager->reconfServer()
#10 /opt/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#11 {main}

2012-06-20T01:08:32+01:00 ERR (3): Apache config (13401509110.67432500) generation failed: apache2: Syntax error on line 227 of /etc/apache2/apache2.conf: Syntax error on line 6 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 10 of /opt/psa/admin/conf/generated/13401509110.67432500_horde.include: Syntax error on line 5 of /opt/psa/admin/conf/webmail_horde_bootstrap.conf: Could not open configuration file /opt/psa/admin/conf/generated/13396983610.98222900_festhome_com_webmail.include: No such file or directory

apache2: Syntax error on line 227 of /etc/apache2/apache2.conf: Syntax error on line 6 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 10 of /opt/psa/admin/conf/generated/13401509110.67432500_horde.include: Syntax error on line 5 of /opt/psa/admin/conf/webmail_horde_bootstrap.conf: Could not open configuration file /opt/psa/admin/conf/generated/13396983610.98222900_festhome_com_webmail.include: No such file or directory

PleskUtilException: /opt/psa/admin/bin/httpdmng '--reconfigure-server' '-no-restart' failed with message: Empty error message from utility.
file: /opt/psa/admin/plib/common_func.php3
line: 1065
code: 0
trace: #0 /opt/psa/admin/plib/common_func.php3(983): util_exec('httpdmng', Array, Array, 'msg', NULL)
#1 /opt/psa/admin/plib/Os.php(17): smart_exec('httpdmng', Array, Array, 'msg')
#2 /opt/psa/admin/plib/Os.php(28): Os::exec('httpdmng', Array, 'msg')
#3 /opt/psa/admin/plib/api-common/Httpdmng.php(89): Os::execEx('httpdmng', Array)
#4 /opt/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#5 {main}

Execution failed.
Command: httpdmng
Arguments: Array
(
[0] => --reconfigure-server
[1] => -no-restart
)

Details: Empty error message from utility.

Any help will be greatly appreciated. Thanks.
 
Having the same issue.

Can you elaborate on which conf file and and your solution?
 
Back
Top