1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk Control Panel

Discussion in 'Plesk for Linux - 8.x and Older' started by theman17, Oct 4, 2005.

  1. theman17

    theman17 Guest

    0
     
    My Plesk Control Panel recently started acting weird after an update from 7.5.2 to 7.5.4 It looks as though the upgrade went ok (no errors) but whenever I try to complete an action (say adding a domain) I get an html page filled with Binary Garbage characters. If you look at the source the very first line is
    #!/usr/local/psa/admin/bin/php

    then followed by the binary characters. I'm wondering if Plesk uses a binary loader like IonCube or something? When I do a php -v on the Plesk php it tells me version 5.04 is now installed and that's it. On the systems php (/usr/bin/php) a -v tells me it's at version 4.4 with IonCube loader installed. I have posted recently with this problem but doesn't seem anyone recognizes this. Perhaps someone who knows how the Plesk Control panel php works could shed some light for me. Everything is still functional and working on the server, it's just the Control Panel that won't let me complete any actions. Thanks in advance for any help and time spent on this.
     
  2. Cranky

    Cranky Guest

    0
     
    Try restarting Plesk:

    service psa restart

    I've seen it occur, but it resolved itself every time. I think it's probably just Plesk admin server not restarting correctly so it needs a push manually.
     
  3. theman17

    theman17 Guest

    0
     
    Thanks Cranky, I tried that but it didn't work. I got the same result. I was wondering maybe if someone else who is running Plesk 7.5.4 can post the results of their /usr/local/psa/admin/bin/php -v

    and if possible
    /usr/local/psa/admin/bin/php -i

    then maybe I can compare my build to the others out there. Thanks again for the support
     
  4. Cranky

    Cranky Guest

    0
     
    PHP 5.0.4 (cli) (built: Aug 24 2005 13:09:33)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
    with eAccelerator v0.9.3, Copyright (c) 2004-2004 eAccelerator, by eAccelerator

    You shouldn't need the -i as if you're running PHP 5.0.4 you should be able to access Plesk 7.5.4, if you're not, you have a problem.
     
  5. theman17

    theman17 Guest

    0
     
    Thanks again Cranky, but it looks as though I have the exact same version. I was wondering what the -i would give you so I could compare my build and see if anything is missing but chances are probably not. This is sooo frustrating everything is still functioning (emails, dns, websites, database...) but when you try to complete an action in the plesk control panel you get a page filled with binary characters. I figure it's trying to load a binary file and having troubles doing it... I wonder could my plesk pages be corrupt? How could I restore the pages in my psa app directory? Thanks as always for the help:)
     
Loading...