1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk down with upgrade to php 4.4.1

Discussion in 'Plesk for Linux - 8.x and Older' started by phatPhrog, Dec 12, 2005.

  1. phatPhrog

    phatPhrog Guest

    0
     
    Okay, to start I will say this is entirely my fault.

    After running a yum update sites no longer connected to their databases after php was upgraded to 4.4.1.

    I did some research, and must emphasize "some" because after reading about a problem with 4.4.1 I foolishly stopped researching.

    We are running a Plesk 7.5.4 - all updates and patches from Fedora and ART.

    Version psa v7.5.4_build75051014.16 os_FedoraCore 2
    OS Linux 2.6.11.9-050512a

    Laugh, that's all I can do for such a stupid move; at least I am admitting it. :)

    The problem:

    I wanted to rollback the upgrade manually and when doing so did NOT stop psa, thus Plesk no longer works, in addition to any other plesk/plesk php functions. As a matter-a-fact there are files/dir that no longer exist due to my lackluster fix. :rolleyes:

    Without re-imaging the server is there anyway to get migration working?

    We have tried unsuccessfully, of course, to migrate the client/sites, etc from another Plesk server of same config without success for - obvious reasons.

    We do have backups for a server restore, but would rather try to migrate without taking any of our other client sites down in the process.

    Is there hope in this or should we just re-image?

    Any and all help will be most appreciated.
     
  2. Cranky

    Cranky Guest

    0
     
    There should be no need to down Plesk in order to upgrade PHP as it's unrelated. What exactly did you do to downgrade? It may be worthwhile getting someone to take a look at your server.
     
  3. phatPhrog

    phatPhrog Guest

    0
     
    Plesk 7.5.4 broken

    We just ran a yum remove and then yum install for php to restore it to the former version.

    When going to our Plesk login we now get:

    StatInfo->getProductVersion failed: file_get_contents() failed:
    0: /usr/local/psa/admin/plib/common_func.php3:25 psaerror(string "StatInfo->getProductVersion failed: file_get_contents() failed: ")
    1: /usr/local/psa/admin/htdocs/login.php3:28 getProductNameVersion()

    Thanks for the input but we guess it's restore time.
     
  4. phatPhrog

    phatPhrog Guest

    0
     
    Fix in the works

    Okay, since my last post I found

    http://forum.ev1servers.net/showthread.php?p=349663

    which prompted me to look at the /usr/local/psa/version, which I found to be an empty file.

    Fortunately I had a copy of the component info so I inserted the version info in that file which restored access to Plesk.

    I was required to go through a few processes to restore the proper license but ultimately restored Plesk somewhat.

    There are still a lot of broken features. Had to manually install a few things, but we're still without the ability to use migration (reinstalled) or any backup features.

    The error received using migration from a working server to this one is

    I followed instructions from the knowledgebase and found no errors, yet the migration still doesn't work.

    No matter, we're getting somewhere. :)

    When attempting to use backup we get the following

    Is there a way to reinstall psa using rpm without using --force or --nodeps that may restore all functions to their previous state?

    If so, please offer the command line to do so.

    We tried running the autoinstaller and keep getting a %post error upon completion without breaking Plesk again.

    This is as much a help for others as it is a request for further information.

    Thanks a bunch.
     
Loading...