1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk not writing into apache

Discussion in 'Plesk for Linux - 8.x and Older' started by KudosDesigns, Mar 7, 2005.

  1. KudosDesigns

    KudosDesigns Guest

    0
     
    Hi,

    I have had no end of problems with the set up of Plesk 7.5.2.

    My lastest query concerns Plesk not actually writing into Apache. Although i have managed to set up hosting for domains in the plesk interface, there are no files in the individual conf/ directories in the website directories, and the httpd.include file contains no reference to any other websites.

    I have no idea why Plesk isn't writing into Apache, and any help on this would be much apprechiated.

    Here is my httpd.include file (i'm sure it should reference my virtually hosted domains ... but i can't find any reference to them!):
    ---------------------------------------
    NameVirtualHost 80.253.122.143:80
    NameVirtualHost 80.253.122.84:80
    NameVirtualHost 80.253.122.85:80
    NameVirtualHost 80.253.122.143:443
    NameVirtualHost 80.253.122.84:443
    NameVirtualHost 80.253.122.85:443
    ServerName plesk.cbitsnet.com
    ServerAdmin serveradmin@kudoswebsolutions.com

    DocumentRoot /home/httpd/vhosts/default/htdocs

    <Directory "/home/httpd/vhosts">
    AllowOverride All
    Options SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    php_admin_flag engine off
    </Directory>

    <Directory "/var/mailman">
    AllowOverride All
    Options SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    php_admin_flag engine off
    </Directory>

    <IfModule mod_userdir.c>
    UserDir disabled
    </IfModule>
    <VirtualHost \
    80.253.122.143:80 \
    80.253.122.84:80 \
    80.253.122.85:80 \
    >
    ServerName default
    UseCanonicalName Off
    DocumentRoot /home/httpd/vhosts/default/htdocs
    ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>
    <Directory "/home/httpd/vhosts/default/cgi-bin/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /home/httpd/vhosts/default/htdocs>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_value open_basedir "/home/httpd/vhosts/default/htdocs:/tmp"
    </IfModule>
    </Directory>
    </VirtualHost>


    <IfModule mod_ssl.c>

    <VirtualHost 80.253.122.84:443 >
    ServerName default-80-253-122-84
    UseCanonicalName Off
    DocumentRoot /home/httpd/vhosts/default/httpsdocs
    ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
    SSLEngine on
    SSLVerifyClient none
    SSLCertificateFile /usr/local/psa/var/certificates/certXXutlfc
    <Directory "/home/httpd/vhosts/default/cgi-bin/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /home/httpd/vhosts/default/httpsdocs>
    SSLRequireSSL
    </Directory>
    </VirtualHost>

    <VirtualHost 80.253.122.85:443 >
    ServerName default-80-253-122-85
    UseCanonicalName Off
    DocumentRoot /home/httpd/vhosts/default/httpsdocs
    ScriptAlias /cgi-bin/ "/home/httpd/vhosts/default/cgi-bin/"
    SSLEngine on
    SSLVerifyClient none
    SSLCertificateFile /usr/local/psa/var/certificates/certXXutlfc
    <Directory "/home/httpd/vhosts/default/cgi-bin/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /home/httpd/vhosts/default/httpsdocs>
    SSLRequireSSL
    </Directory>
    </VirtualHost>

    </IfModule>

    <VirtualHost \
    80.253.122.143:80 \
    80.253.122.84:80 \
    80.253.122.85:80 \
    >
    DocumentRoot /home/httpd/vhosts/webmail
    ServerName webmail
    ServerAlias webmail.*
    UseCanonicalName Off
    <Directory /home/httpd/vhosts/webmail/horde>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/home/httpd/vhosts/webmail:/etc/psa:/tmp"
    php_admin_value include_path "/home/httpd/vhosts/webmail/horde/lib:/home/httpd/vhosts/webmail/horde/pear:."
    </IfModule>
    </Directory>
    </VirtualHost>


    <IfModule mod_ssl.c>

    <VirtualHost \
    80.253.122.143:443 \
    80.253.122.84:443 \
    80.253.122.85:443 \
    >
    DocumentRoot /home/httpd/vhosts/webmail
    ServerName webmail
    ServerAlias webmail.*
    UseCanonicalName Off
    SSLEngine on
    SSLVerifyClient none
    SSLCertificateFile /etc/httpd/conf/httpd.pem
    <Directory /home/httpd/vhosts/webmail/horde>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag magic_quotes_gpc off
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/home/httpd/vhosts/webmail:/etc/psa:/tmp"
    php_admin_value include_path "/home/httpd/vhosts/webmail/horde/lib:/home/httpd/vhosts/webmail/horde/pear:."
    </IfModule>
    SSLRequireSSL
    </Directory>
    </VirtualHost>


    </IfModule>

    <VirtualHost \
    80.253.122.143:80 \
    80.253.122.84:80 \
    80.253.122.85:80 \
    >
    DocumentRoot /home/httpd/vhosts/default/htdocs
    ServerName lists
    ServerAlias lists.*
    UseCanonicalName Off
    ScriptAlias /mailman/ /var/mailman/cgi-bin/
    Alias /icons/ /var/www/icons/
    Alias /pipermail/ /var/mailman/archives/public/
    <Directory /var/mailman/archives/>
    Options FollowSymLinks
    </Directory>
    </VirtualHost>


    <IfModule mod_ssl.c>

    <VirtualHost \
    80.253.122.143:443 \
    80.253.122.84:443 \
    80.253.122.85:443 \
    >
    DocumentRoot /home/httpd/vhosts/default/httpsdocs
    ServerName lists
    ServerAlias lists.*
    UseCanonicalName Off
    ScriptAlias /mailman/ /var/mailman/cgi-bin/
    Alias /icons/ /var/www/icons/
    Alias /pipermail/ /var/mailman/archives/public/
    <Directory /var/mailman/archives/>
    Options FollowSymLinks
    </Directory>
    </VirtualHost>


    </IfModule>

    Thanks for any help,

    nick
     
Loading...