• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Question Plesk Onyx Update Problem

sende2

New Pleskian
Hello there,

I have a windows 2008 server.

Running Plesk 12.5 on it.
I want to upgrade the Plesk version and then migrate the server to Windows 2019.
However, when I try to upgrade, I get an error. I haven't been able to solve the problem. I want your help in this matter.

ERROR:

Components and product validation detected at least one important issue:
Plesk pre-upgrade checking...
FATAL_ERROR: [MYSQL ERROR] Given <password> is incorrect. Access denied for us
er 'psa_root'@'localhost' (using password: YES)


Proceeding with installation or upgrade without resolving the issues
that were found can corrupt your data.

Do you want to continue? [y/n]:

pleskerror.jpg

Thank you,
 
What is the output of the command:

C:\> netstat -a | findstr 3306

Let me please share with you the following information.

In Plesk on Windows, there are two SQL servers:

1. Plesk SQL server which is listening on the port 8306 and contains system databases like psa and using under admin username.

2. Clients MySQL server which is listening on the port 3306 and using for the clients' databases.

The issue with the Pre-upgrade checker occurs because you are trying to specify the password from the clients MySQL server instead of admin Plesk SQL server.

To fix the issue please follow the steps:

1. Open CMD and execute the command to get admin password from Plesk SQL Server:
"%plesk_bin%\\plesksrvclient.exe" -get

2. Run the Pre-upgrade checker and specify the password that you got on step 1.
 
Back
Top