1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk panel showing 500 - Internal Server Error

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by midadala, Aug 23, 2011.

  1. midadala

    midadala Guest

    0
     
    Hi,

    When tried to access my plesk 9.3 today., it showed the below error

    500 - Internal Server Error

    Below is the log of sw-cp-server

    2011-08-23 14:03:30: (mod_fastcgi.c.1000) the fastcgi-backend /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm failed to start:
    2011-08-23 14:03:30: (mod_fastcgi.c.1004) child exited with status 1 /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm
    2011-08-23 14:03:30: (mod_fastcgi.c.1007) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
    You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
    For more information check http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
    2011-08-23 14:03:30: (mod_fastcgi.c.1012) If this is PHP on Gentoo add fastcgi to the USE flags
    2011-08-23 14:03:30: (mod_fastcgi.c.1105) [ERROR]: spawning fcgi failed.
    2011-08-23 14:04:42: (log.c.135) server stopped
    2011-08-23 14:04:50: (log.c.75) server started
    2011-08-23 14:04:50: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2011-08-23 14:04:50: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    Must be suid root
    2011-08-23 14:05:21: (mod_fastcgi.c.1000) the fastcgi-backend /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm failed to start:
    2011-08-23 14:05:21: (mod_fastcgi.c.1004) child exited with status 1 /usr/bin/sw-engine-cgi -c /usr/local/psa/admin/conf/php.ini -d auto_prepend_file=auth.php3 -u psaadm
    2011-08-23 14:05:21: (mod_fastcgi.c.1007) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
    You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
    For more information check http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
    2011-08-23 14:05:21: (mod_fastcgi.c.1012) If this is PHP on Gentoo add fastcgi to the USE flags
    2011-08-23 14:05:21: (mod_fastcgi.c.1105) [ERROR]: spawning fcgi failed.
    2011-08-23 14:05:21: (mod_fastcgi.c.3505) all handlers for /index.php on .php are down.
    2011-08-23 14:05:32: (log.c.135) server stopped
    2011-08-23 14:05:36: (log.c.75) server started
    2011-08-23 14:05:36: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2011-08-23 14:05:36: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs


    And below is the content of my /usr/local/psa/admin/conf/php.ini

    short_open_tag = On
    y2k_compliance = Off
    output_buffering = Off
    allow_call_time_pass_reference = On
    max_execution_time = 600
    max_input_time = 600
    memory_limit = 128M
    error_reporting = E_ALL & ~E_NOTICE
    log_errors = On
    display_errors = On
    warn_plus_overloading = Off
    expose_php = Off

    variables_order = "ECGPS"
    register_argc_argv = On
    auto_globals_jit = Off
    post_max_size = 2147483647
    magic_quotes_gpc = On
    magic_quotes_runtime = Off

    include_path = "/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin"
    upload_tmp_dir = "/tmp"
    upload_max_filesize = 2147483647

    #apc.stat = 0
    #apc.shm_size = 10
    #apc.include_once_override = 1

    swkey.repository_dir = "/etc/sw/keys" q


    Thanks
    Murali
     
    Last edited by a moderator: Aug 23, 2011
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Do you have enabled Greylisting spam protection?
     
  3. midadala

    midadala Guest

    0
     
    Hi
    Grey_listing is disabled. Below is the output for grey_listing --info-server


    Grey listing configuration.

    Grey listing checking disabled
    Grey interval 5 minutes
    Expire interval 51840 minutes
    Penalty interval 2 minutes
    Penalty disabled
    Personal grey listing
    configuration allowed

    Server-wide black list:

    Server-wide white list:

    White domains patterns list:
    *google.com
    *mail.ru
    *parallels.com
    *rambler.ru
    *yahoo.com
    *yandex.ru

    Black domains patterns list:
    *[0-9][0-9]-[0-9][0-9]-[0-9][0-9]*
    *[0-9][0-9].[0-9][0-9].[0-9][0-9]*
    *[0-9][0-9][0-9]-[0-9][0-9][0-9]-[0-9][0-9][0-9]*
    *[0-9][0-9][0-9].[0-9][0-9][0-9].[0-9[0-9]][0-9]*
    dsl|pool|broadband|hsd
    dynamic|static|ppp|dyn-ip|dial-up

    SUCCESS: Gathering of server wide information complete.
     
  4. midadala

    midadala Guest

    0
     
Loading...