1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Plesk returns "Unable to create Domain object: displayName != name"

Discussion in 'Plesk for Linux - 8.x and Older' started by DennisCitus, Jul 7, 2005.

  1. DennisCitus

    DennisCitus Guest

    0
     
    I have a problem with a domain created by a reseller.

    Clicking on the domain in Plesk gives this error:
    Selecting it and pressing the "REMOVE"-button gives this error:
    Googling and searching on the board has let me to 1 answer; restarting the PSA-service. But this didn't work for me.

    I found out that the domain is created with Physical Hosting, but there is no /home/httpd/vhosts/domain.ext directory. Neither is there /var/qmail/mailnames/domain.ext. So something must've gone wrong creating the domain in Plesk.

    What could cause this error?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Not sure, but have you checked that the domain name they created does not contain illegal characters, and that they didn't try to create a domain which already exists (under any client account)? Forgive me if I don't make sense, I have (again) gone too long without sleep.

    First thing I would do is SSH as root to the server and do:

    locate baddomain.com |grep '/home/httpd/'

    and see if there is any duplication of the domain name.

    I would then also check/verify group ownership as psacln on the domain folder

    You may have already done these things and not said so in your post, so just want to throw them out there (for future readers who may not have checked)
     
  3. DennisCitus

    DennisCitus Guest

    0
     
    You are right, this is essential information indeed. I had already checked it, but didn't post it. I edited my topicstart.
     
  4. DennisCitus

    DennisCitus Guest

    0
     
    Please, anybody?
     
  5. DennisCitus

    DennisCitus Guest

    0
     
    F*ck Plesk :)

    I really think they should support such issues. Just because these issues are caused by bugs in their software.
     
  6. DennisCitus

    DennisCitus Guest

    0
     
    (First domain = name, second is displayname)
    237 2005-07-05 veilinggebouw.com veilingebouw.com false master 0 vrt_hst 34738176 28 0 266 0

    Changing "veilingebouw" to "veilinggebouw" solved the problem. I have no idea how this strange thing could've happened, veilingebouw using one g is a common mistake in Dutch, so it has probably been mistyped. But it should not cause Plesk to show errors, so I can't admin the domain anymore.
     
  7. noslzzp

    noslzzp Guest

    0
     
    Did anyone get an answer to this? We have just purchases Plesk (under HSPc) and got the following:

    ERROR: Unable to create PhDomain object: PhDomain: unable to select: no such row in the table 0: /usr/local/psa/admin/auto_prepend/auth.php3:284 psaerror(string "Unable to create PhDomain object: PhDomain: unable to select: no such row in the table")


    Also associated with this domain name is the LACK of httpd.include files! So the site never comes up!

    The domain name looks like this:

    f-9-x.com

    Is Plesk "dash" friendly?!
     
  8. ShadowMan@

    ShadowMan@ Guest

    0
     
    If the domain was created in Plesk with 2 g's, then manually renamed to a single g, I can see that causing problems since Plesk would then not know where to find the domain files. Don't know if this is what happened or not...
    I know for a fact that domains with a single dash are not a problem, I have never tried a domain with multiple dashes though, so I'm not sure.

    Ok, just tested it. I was able to use a test server, created the domain 'double-dash-domain.com', setup physical hosting for it, got no errors. I suppose I could try some domain name quite similar to yours.

    Ok, was able to create the domain 'f-9-y.com' again same as the last, physical hosting, no errors.

    The only difference I can see is that I am not running with HSPc, my test server is a standalone dedicated.
     
  9. noslzzp

    noslzzp Guest

    0
     
    Hey thanks for the reply.. And yes, we are using Plesk under HSPcomplete. We are still having problems with provisioning accounts. It seems all goes well except the creation of the httpd.include files. We though t is was related to domains with "-" in them, but we just tried to provision a "normal" domain and we get the same missing httpd.include file.

    We have a support ticket in with SWSoft to get this resolved. We signed up our first customer, experienced this problem and the customer cancelled, of course. :(

    So much for "progress"..
     
Loading...