1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk8 Error - Apache can't be restarted

Discussion in 'Plesk for Linux - 8.x and Older' started by zitronenmaennch, May 8, 2006.

  1. zitronenmaennch

    zitronenmaennch Guest

    0
     
    Hi there,

    I use Plesk 8 and when I create a new domain (mostly this happens when several domains have been created) the apache won't restart. (which I think it starts new after a domain is created?

    This is the follwing error code:

    PHP:
    0: /usr/local/psa/admin/plib/common_func.php3:169
    psaerror
    (string 'Unable to make action: Unable to manage service by websrvmng: websrvmng: Service apache2 failed to start')
    1: /usr/local/psa/admin/htdocs/server/restart_services.php:30
    Even trying to start the apache manually does not work.

    The only way to get Apache running again is a complete reboot of the server.

    This is a from the apache2 error log:


    PHP:
    Configuration Failed
    [Mon May 08 22:14:31 2006] [warnInitSession Cache is not configured [hintSSLSessionCache]
    [
    Mon May 08 22:14:31 2006] [warnRSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon May 08 22:14:31 2006] [warn] RSA server certificate CommonName (CN) 
    `plesk' does NOT match server name!?
    [Mon May 08 22:14:31 2006] [crit] (28)No space left on device: mod_rewrite: could not create rewrite_log_lock
    Configuration Failed
    [Mon May 08 22:15:06 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon May 08 22:15:06 2006] [warn] RSA server certificate CommonName (CN) `plesk' 
    does NOT match server name!?
    [
    Mon May 08 22:15:06 2006] [warnRSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon May 08 22:15:06 2006] [crit] (28)No space left on device: mod_rewrite: could not create rewrite_log_lock
    Configuration Failed
    [Mon May 08 22:16:45 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon May 08 22:16:45 2006] [warn] RSA server certificate CommonName (CN) 
    `plesk' does NOT match server name!?
    [Mon May 08 22:16:45 2006] [warn] RSA server certificate CommonName (CN) `plesk' 
    does NOT match server name!?
    [
    Mon May 08 22:16:45 2006] [noticesuEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [
    Mon May 08 22:16:45 2006] [warnRSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon May 08 22:16:45 2006] [warn] RSA server certificate CommonName (CN) 
    `plesk' does NOT match server name!?
    [Mon May 08 22:16:46 2006] [notice] mod_python: Creating 32 session mutexes based on 150 max processes and 0 max threads.
    [Mon May 08 22:16:46 2006] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations

    Well, this is some awfull bug or whatever. Please help to fix this problem.

    Thx in advance,

    Z
     
  2. ZopfWare

    ZopfWare Regular Pleskian

    25
    57%
    Joined:
    May 30, 2004
    Messages:
    215
    Likes Received:
    0
    Hmmm...I would not worry too much about the Common Name (CN) errors but the other one about mod_rewrite... sounds like you have run out of space on one of your partitions.

    run a #df on your server and take a look at the space available on all your partitions. Especially look at the partition that has your /tmp dir in it. If need be, set up a symlink ofr the /tmp dir pointing it to something like your home dir where you have some extra space.

    Just a thought..
     
  3. zitronenmaennch

    zitronenmaennch Guest

    0
     
    Hi,

    thx for your answer. But I have aprox. 95 GB of space left, so this couldn't really be the problem. But I also wonder, why the log says, no space is available.

    Any other ideas?

    Z
     
  4. massilia

    massilia Guest

    0
     
    I have the same problem please fix this bug :)

    After i create a new domaint he only way to get Apache running again is a complete reboot of the server.:mad:
     
  5. crossconnect

    crossconnect Guest

    0
     
  6. zitronenmaennch

    zitronenmaennch Guest

    0
     
    Thx for the Hint. This will hopefully help to let Apache restart in console without rebooing whole server. But it still doesn't fix the problem with the webservicemanager. I guess, this is a problem by plesk. Maybe someone from swsoft could give us a hint here?

    Z
     
  7. crossconnect

    crossconnect Guest

    0
     
    No, I don't think it is a Plesk problem at all. If you can't start Apache using apachectl (or service httpd start, or whatever you usually do) then Plesk websrvmng won't be able to do it either.
     
  8. zitronenmaennch

    zitronenmaennch Guest

    0
     
    But this problem only occures, when a domain is created with plesk. So I guess, this has something to do with plesk itself.
     
  9. massilia

    massilia Guest

    0
     
    I can restart Apache at will with plesk when no modification is applied, but when I want to modify something (like disable safe mode for example), I got the same error as above when I try to restart Apache.

    Plesa a fix from plesk !!!!!!!:(
     
  10. crossconnect

    crossconnect Guest

    0
     
    It's most likely an error in the config modifications you have made. Check the Apache server error log (not the one for the domain) and it should tell you what is tripping it up. Also, you can run service httpd configtest (or /path/to/apachectl configtest) and it will scan the configuration for errors. If there are no errors it is safe to restart Apache in the normal way.

    Just in case it is something to do with not Plesk mucking up httpd.include, what I would do is try creating a blank vhost.conf and see if you have the same problem. If it works OK, then start to add your configurations in vhost.conf (but run configtest first).
     
  11. massilia

    massilia Guest

    0
     
    configtest is good

    :confused: :confused: :confused: :confused: :confused: :confused: :confused: :confused: :confused: :confused:
     
  12. nmathon

    nmathon Guest

    0
     
    I have the same problem. Anyone have a solution ?

    Nicolas
     
  13. massilia

    massilia Guest

    0
     
    I fix this problem with this command :)

    /usr/local/psa/admin/sbin/websrvmng -a
    /usr/local/psa/admin/sbin/websrvmng -r
     
  14. nmathon

    nmathon Guest

    0
     
    grrr... It doesn't work.
    I just update Plesk and create a domain with "safe mod" off and now i can't restart apache.
     
  15. nmathon

    nmathon Guest

    0
     
    It's OK; It wasn't the same problem. It was ioncube which does'nt work with eacelerator.

    Thanks for help.
     
Loading...