• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Postfix delivery error

H

hr.kam

Guest
Hello, after we are switching from qmail to postfix, email queue starts growing and postfix starts produce errors.
Some emails are delivered without problem but many stays in deferred que.

postqueue -p display this error:

"(temporary failure. Command output: sh: /usr/sbin/sendmail: No such file or directory 4.2.1 Message can not be delivered at this time)"

We have latest Plesk version (10.3.1) on CentOS 5. All updates are installed.

Please, Any advice?

Thank you.

Sorry for my english. Im not native speaker.
 
Do you have the same structure?

# ls -la /usr/sbin/sendmail
lrwxrwxrwx 1 root root 21 Apr 21 2011 /usr/sbin/sendmail -> /etc/alternatives/mta
# ls -la /etc/alternatives/mta
lrwxrwxrwx 1 root root 26 Nov 9 16:56 /etc/alternatives/mta -> /usr/sbin/sendmail.postfix
 
No, second is different:

# ls -la /etc/alternatives/mta
lrwxrwxrwx 1 root root 23 Nov 10 13:26 /etc/alternatives/mta -> /var/qmail/bin/sendmail
 
I was try reinstall postfix with this command:
/usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component postfix

but I recived:
Parallels Containers were detected. Trying to connect to VZAgent...Warning! Failed to connect to VZAgent: open: No such device or address
Detecting installed product components.
You already have the latest version of product(s) and all selected components installed. Installation will not continue.

I was send some test emails. Some accounts works well, but some accounts didnt recive message. This messages still stay in deffered queue. Most of this problematic accounts has forward to another account. For example: account servis is forwarded to another three accounts.

Perhaps it will be useful.

Thank you for your care.

One more thing. Is it possible update to PLesk 10.4? Maybe, this helps.
 
Last edited by a moderator:
Back
Top