1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems with 10.2.0 and Suse 11.4

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by NorbertM, Apr 29, 2011.

  1. NorbertM

    NorbertM Guest

    0
     
    Greetings!

    After installation of SuSE 11.4 and Plesk 10.2.0 I experience the following problems:

    - Firewall: Settings made in plesk are NOT set at systemstart. I need to log into the control panel, click on "change settings" and activate them. This is very annoying because that way mailclients can't connect from outside.

    - Postfix: Not working anymore (worked flawless with plesk 10.1 though). The usual queue-error many others experience now.

    - Qmail: Since ages qmail doesn't set the hostname correctly in /var/qmail/control/me it is only servername. instead of servername.dom.tld (some german providers will lock you out after a few emails sent to their servers if you don't use the fully qualified name)

    Quite a few messages like the following appear:
    insserv: warning: script 'S01psa-firewall' missing LSB tags and overrides
    insserv: warning: script 'psa-firewall-forward' missing LSB tags and overrides
    insserv: Default-Start undefined, assuming default start runlevel(s) for script `psa-firewall-forward'
    insserv: warning: script 'psa-firewall' missing LSB tags and overrides


    Looks like Plesk doesn't follow certain guidelines the system expects. But this already happened with SuSE 11.3.
     
  2. rosskendall

    rosskendall Basic Pleskian

    17
     
    Joined:
    Oct 13, 2010
    Messages:
    41
    Likes Received:
    0
    I'm also noticing some firewall problems with 10.2 and openSUSE 11.4. The firewall is blocking DNS even though the settings show it as enabled. Strangely I didn't see the problem with 10.2 and openSUSE 11.3.

    Unfortunately changing the firewall settings and 'activating' doesn't solve the problem for me.

    (I also noticed the insserv warnings, but I suspect it is only that - warnings)
     
  3. rosskendall

    rosskendall Basic Pleskian

    17
     
    Joined:
    Oct 13, 2010
    Messages:
    41
    Likes Received:
    0
    OK, I found my problem and it wasn't the firewall!

    The reason DNS wasn't working for me with openSUSE 11.4 was that the default config /etc/named.conf had the following line:
    listen-on { 127.0.0.1; };
    (which means the nameserver doesn't respond to requests on external IP addresses)
    This wasn't the case with openSUSE 11.3, so it caught me out.
    Commenting out the line and restarting the named service fixed my issue.
     
Loading...