1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems with backingup/restoring backups

Discussion in 'Plesk for Linux - 8.x and Older' started by Weissbierwaldi, Apr 15, 2007.

  1. Weissbierwaldi

    Weissbierwaldi Guest

    0
     
    Hello

    i just installed a new linux on my server.

    Before i backuped all clients manually on a ftp-server. Than i made an backup of all clients via console.

    Than after the installation was complete i upgraded Plesk to the old version (8.1.1).
    Than i restored the backup off all clients via console. No errors ocoured during restore.

    After the backup was complete i found out, that some domains don't have their old files in the httpdocs and httpsdocs, only the standard files.

    So I resored every client seperate from the ftp-server. This worked fine except one domain. There mysql said, that one key is bigger than 1000 byte or something like that.

    I solved this error.
    I had to set the database encoding to latin_general_ci before it was utf8_general_ci.
    Than i opened the backup on my pc and i had to copy the database and insert it manually.

    But later i wondered why i couldn't post on a forum which was on one domain.
    So i looked at the database and i saw that all auto-increment colums and on-update-set-current-timestamp options where missing.
    And now all scripts don't work because this error.
    I have to create the tables new and insert the old content.


    Is it a bug, that plesk makes incomplete backups of a mysql database?
    And why didn't plesk restore all the files from all clients correctly?

    If this is errors happen with every backup i won't take them with plesk anylonger.
     
Loading...