1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ProFTPD / Xinetlog empty after Plesk update 9.2.2

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by OlivierT, Oct 29, 2009.

  1. OlivierT

    OlivierT Guest

    0
     
    Hi,

    Since I updated Plesk to 9.2.2 in CentOS 5.4, xferlog in /usr/local/psa/var/log stays empty.
    Before the update, it worked, the file xferlog.processed is still full of entries.
    Permissions look like to be ok too :
    #ls -la /usr/local/psa/var/log
    drwxr-xr-x 2 psaadm psaadm 4096 oct 29 10:00 .
    drwxr-xr-x 10 psaadm psaadm 4096 oct 28 17:21 ..
    -rw-r----- 1 root root 34388 oct 29 10:18 maillog
    -rw-r----- 1 root root 7108715 oct 29 04:08 maillog.processed
    -rw-r--r-- 1 root root 0 oct 29 04:08 smtp_pendings.log
    -rw-r--r-- 1 root root 0 oct 27 04:02 xferlog
    -rw-r--r-- 1 root root 685262 oct 27 04:02 xferlog.processed

    I didn't modify proftpd.conf :
    # Primary log file mest be outside of system logrotate province
    TransferLog /usr/local/psa/var/log/xferlog

    I tried to restart xinetd service but it didn't change anything.
    ProFTPD works as asual, my users can connect wihout problem but no entry is written in xferlog which is very annoying.

    Any suggestion would be very appreciated,
    Thanks
     
  2. OlivierT

    OlivierT Guest

    0
     
    In fact it's OK, xferlog grows normally now.
    It was empty because only file transfers are recorded in xferlog, not the connection attempts to ProFTPD.
    Sorry for that post.
     
Loading...