1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Protected directories - Apache tries to read wrong .htaccess

Discussion in 'Plesk for Linux - 8.x and Older' started by akxak, Jan 24, 2006.

  1. akxak

    akxak Basic Pleskian

    23
    23%
    Joined:
    Jan 23, 2006
    Messages:
    34
    Likes Received:
    0
    Hi!

    On a quite new server (Suse 9.3, Plesk 7.5.4) I have a problem with protected directories. All hints from other threads did not show a solution.

    The directory is protected using the Plesk interface.

    Plesk stores the user credentials in a special file under /pd of the domain directory and adds an appropriate record to httpd.include under /conf.

    So far, everything is there.

    BUT:

    Apache does not seem to recognize the section in httpd.include properly.

    [crit] [client 84.44.179.200] (13)Permission denied: /home/httpd/vhosts/xxxxxx.xx/httpdocs/cgiproxy/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable.

    Apache tries to access .htaccess which it expects in the protected directory.

    The entry AuthUserFile in httpd.include pointing to /pd/d..cgiproxy is obviously ignored.

    The problem persists independed of the setting of custom error documents.

    Any explanation for the behaviour of Apache under Plesk?

    Bye,

    Andreas
     
Loading...