1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

QMail-Alias is not working

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Thomas Wilhelmi, Aug 4, 2009.

  1. Thomas Wilhelmi

    Thomas Wilhelmi Regular Pleskian

    24
    40%
    Joined:
    Aug 4, 2009
    Messages:
    102
    Likes Received:
    4
    Hallo,

    I use Plesk 9.2.2 with QMail as Mailing-system. The following alias-definitions where predefined in my config:

    All contains the same line:

    This works for the most important addresses "root" and "postmaster". But not for "mailman". I than created 2 new alias-files "kluser" and "drweb" for cronjobs running under this users. I created them with the command "cp .qmail-root .qmail-drweb" and "cp .qmail-root .qmail-kluser". This works for the kluser-alias. But not for "drweb". The Logfile for both ("drweb" and "mailman") contains the follwing:

    I notice that QMail tries to access the Mailbox of this user. But shouldn't it use the alias-entry before it tries to go to the Homedir? And why does it work for "kluser" who has no MailDir as well?

    Thanks and Regards,
    Thomas
     
  2. mruzicka

    mruzicka Guest

    0
     
    Having the same issue

    I'm having the same issue.

    Oct 2 12:06:45 server1 qmail: 1254499605.198076 starting delivery 1: msg 100598722 to local drweb@server1.domain.com
    Oct 2 12:06:45 server1 qmail: 1254499605.198478 status: local 1/10 remote 0/20
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: Handlers Filter before-local for qmail started ...
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: from=anonymous@server1.domain.com
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: to=drweb@server1.domain.com
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: mailbox: /var/drweb
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: hook_dir = '/usr/local/psa/handlers/before-local'
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: recipient[3] = 'drweb@server1.domain.com'
    Oct 2 12:06:45 server1 qmail-local-handlers[22009]: handlers dir = '/usr/local/psa/handlers/before-local/reci
    pient/drweb@server1.domain.com'
    Oct 2 12:06:45 server1 qmail: 1254499605.210052 delivery 1: deferral: ./Maildir:_No_such_file_or_directory/
    Oct 2 12:06:45 server1 qmail: 1254499605.210144 status: local 0/10 remote 0/20


    1. I've tried to create a specific alias for drweb in /var/qmail/alias/.qmail-drweb to by pass the issue - no luck
    2. I've tried to manually create /var/drweb/Maildir - no luck
    3. I've tried to manually create a /var/spool/mail/drweb dir and file - no luck (not surprised here)

    Any other suggestions out there? We can't be the only two with this issue.

    Thanks in advance.
     
  3. mruzicka

    mruzicka Guest

    0
     
    Not ideal, but..

    I just ended up creating a /var/drweb/.qmail file with &root in it. Still testing it, but appears to have at least bypassed the issue.
     
  4. ManuelF

    ManuelF New Pleskian

    20
     
    Joined:
    Oct 22, 2009
    Messages:
    11
    Likes Received:
    0
    solved!

    I had the same problem, finally found a solution that works for me, maybe it helps you out.

    In my qmail-log i also found
    I noticed the file-permissions of /var/qmail/bin/qmail-local were different to qmail-remote
    So I set the owner and group ("chown mhandlers-user:popuser /var/qmail/bin/qmail-local") and the permissions ("chmod g+s /var/qmail/bin/qmail-local") and it worked. I can send mail to drweb ("mail drweb") and finally the cronjob by drweb doesn't reach me from mailer-daemon with failure notice :)

    Hope that helps, good luck.
     
  5. UweF

    UweF Guest

    0
     
    The problem will be solved, when you re-install your locales settings, I think. ;)
     
  6. trialotto

    trialotto Golden Pleskian Plesk Guru

    37
     
    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    206
    Correct solution. Be aware that your problems with the mail server might persist, but that they are not related to ownership.

    Only if you have "permission denied" (or something of the sort), do change the ownership and permissions of qmail-local to that of qmail-remote for example.

    If other problems persist, you can be sure that you still did the good thing with qmail-local.

    Those other problems follow from a bad qmail installation (or more likely: change from postfix to qmail with the autoinstaller).

    Therefore, when problems persist, a simple solution seems to be present: run autoinstaller twice!
    (this helps for sure and makes qmail installation proper)
     
  7. trialotto

    trialotto Golden Pleskian Plesk Guru

    37
     
    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    206
    Correct solution. A similar solution helps for missing mailman mail adresses.

    However, it is practical for one drweb and one or two missing mailman addresses. And then you still are not sure whether all problems are solved, since the missing .qmail files are being caused by another result: a faulty installation procedure.

    My tip: run the autoinstaller twice (change to postfix when having qmail and, after installing postfix, change back to qmail)......this is necessary since qmail is not being installed properly with the autoinstaller (a bug ).

    Even though this seems solution seems strange, it is fast ....and works........and prevents the manual creation of lots of .qmail* files when also missing mailman addresses.
     
  8. AlessandroC

    AlessandroC Guest

    0
     
    @ManuelF: thank you for the correct solution! I'm not receiving the delivery failure notification anymore.
     
  9. DanijelD

    DanijelD Basic Pleskian

    19
    35%
    Joined:
    May 13, 2010
    Messages:
    68
    Likes Received:
    0
    Hi guys.
    I am having problems with setting up Mailman's join list via email feature.

    My configuration: CentOS 5.8, Plesk 11.0.9.

    I am trying to make my mailing list accept another way of joining a list, that is to join the Mailman mailing list by sending email to LISTNAME-join@DOMAIN. But it doesn't work, users get replies "550 sorry, no mailbox here by that name." The list LISTNAME@DOMAIN works fine otherwise.

    Then I researched and found that I need to set aliases for my Qmail. So I added /var/qmail/alias/.qmail-listname-join file with the following contents: |preline /usr/lib/mailman/mail/mailman join listname, but it still does not work.

    How do I set up my Qmail to accept Mailman LISTNAME-join@DOMAIN?
     
  10. trialotto

    trialotto Golden Pleskian Plesk Guru

    37
     
    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    206
    @DanijelD,

    In my post of 23.10.2009 (see above), I have hinted an answer to your question.

    Just convert qmail to postfix and, afterwards, revert from postfix to qmail.

    In most of the cases, this will resolve issues with qmail and/or mailman on qmail.

    Kind regards...
     
  11. DanijelD

    DanijelD Basic Pleskian

    19
    35%
    Joined:
    May 13, 2010
    Messages:
    68
    Likes Received:
    0
    I resolved the issue.
    It was the location of alias files which I found by accident. In Plesk 11, all the .qmail alias files seem to be located per domain in /var/qmail/mailnames/mydomain.com. As soon as I created a .qmail-listname-join file (with only this line in the file: |/var/qmail/bin/preline /usr/lib/plesk-9.0/mm_wrapper /usr/lib/mailman/mail/mailman join listname), all started working normaly. I also restarted QMail, just in case. I wander why was this not documented anywhere.
     
Loading...