• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Qmail not accepting mail from PHP forms

F

fxstar

Guest
Hi all,

We have a particular problem with Qmail on Plesk 8.1.1.

We are having a problem in that pop3/imap and SMTP sending from regular mail clients works fine. However when we use the regular PHP Mail() function we get the following error in the log:

////////
qmail-queue-handlers[24935]: cannot create temporary file - (13) Permission denied
Nov 16 16:02:01 [servername] qmail-queue-handlers[24935]: cannot read message from stdin
Nov 16 16:02:01 [servername] qmail-queue[24934]: starter: submitter[24935] with error code 54
Nov 16 16:02:01 [servername] qmail-queue[24934]: mailsend: wait for submitter failed
Nov 16 16:02:01 [servername] qmail-queue[24934]: cannot reinject message to mail system
////////

Anyone have any ideas? I cannot locate the temp files that it's calling and I've commented out all the sendmail provisions in the php.ini's trying to locate how this is working. No luck thus far.

PS.

At the same time the PHP form is submitted - I see about 100 entries in the /var/log/messages file similar to this:

////////
Nov 16 17:18:13 [servername] kernel: audit(1195251493.428:21020): avc: denied { append } for pid=27425 comm="sendmail" name="access_log" dev=dm-3 ino=212123 scontext=root:system_r:system_mail_t tcontext=root:eek:bject_r:httpd_sys_content_t tclass=file
////////
 
Originally posted by fxstar
Hi all,

We have a particular problem with Qmail on Plesk 8.1.1.

We are having a problem in that pop3/imap and SMTP sending from regular mail clients works fine. However when we use the regular PHP Mail() function we get the following error in the log:

////////
qmail-queue-handlers[24935]: cannot create temporary file - (13) Permission denied
Nov 16 16:02:01 [servername] qmail-queue-handlers[24935]: cannot read message from stdin
Nov 16 16:02:01 [servername] qmail-queue[24934]: starter: submitter[24935] with error code 54
Nov 16 16:02:01 [servername] qmail-queue[24934]: mailsend: wait for submitter failed
Nov 16 16:02:01 [servername] qmail-queue[24934]: cannot reinject message to mail system
////////

Anyone have any ideas? I cannot locate the temp files that it's calling and I've commented out all the sendmail provisions in the php.ini's trying to locate how this is working. No luck thus far.

PS.

At the same time the PHP form is submitted - I see about 100 entries in the /var/log/messages file similar to this:

////////
Nov 16 17:18:13 [servername] kernel: audit(1195251493.428:21020): avc: denied { append } for pid=27425 comm="sendmail" name="access_log" dev=dm-3 ino=212123 scontext=root:system_r:system_mail_t tcontext=root:eek:bject_r:httpd_sys_content_t tclass=file
////////

I bet 10$ it is caused by Selinux ;)
Check selinux status with:
getenforce

if it is in enforcing mode switch it to permissive mode using:
setenforce 1
 
Indeed. You win.

Turns out SELinux decided to quarantine sendmail for some ridiculous reason after a reboot.

Had to get the provider managing the OS to reset the permissions on SELinux and then reset it's profile.

Reminded me of some good ole fun with Tripwire circa 1999.
 
Back
Top