1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail running very slowly

Discussion in 'Plesk for Linux - 8.x and Older' started by mjekovec, Mar 9, 2006.

  1. mjekovec

    mjekovec Guest

    0
     
    We recently purchased Plesk reloaded and installed it on two machines runninng Debian sarge. One dedicated to hosting and the other a dedicated mail server.

    Qmail that was installed by Plesk seems extremly slow. I've already installed and configured tcpserver due to inetd problems and raised limits on concurrent connections.

    It seems, that the problem lays in preprocessing of the queue as only a few (5 -10) qmail-remote processes get spawned. We have spamassasin and drweb installed and configured for all mailboxes.

    Is it normal that this kind of configuration is able to serve 3-5 mails/s on a dual Xeon dual core machines with 2GB RAM (which is not even fully used) and quite cabable RAID disks (var with queue and mailnames is on a separate RAID and the system on another set of drives)

    We have around 1000 domains with about 5000 users total, but i cannot currently tell you anything about the number of messages/hour or day

    Any answer would be welcomed...
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    When you say qmail runs slowly, do you mean during smtp? If so, try editing your smtp_psa file and add:

    -Rt0 just after the " server_args = "

    This will disable reverse lookup here and speed things up considerably for you.
     
  3. mjekovec

    mjekovec Guest

    0
     
    I am not using xinetd, but I included -R -l and similar parameters to the call of tcpserver:

    /usr/bin/tcpserver -v -R -l "$LOCAL" -c $MAXSMTPD -x/etc/tcp.smtp.cdb -X \
    -u "$QMAILDUID" -g "$NOFILESGID" 0 smtps /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true &> /var/log/qmail-smtps.log &
     
Loading...