1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Reconfiguring Apache on host failed

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by fearz, Mar 3, 2011.

  1. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    Hi,

    Whenever a domain is created i receive this notification via email:


    Generating new Apache configuration on hostxx failed because the following error(s) occurred:

    Can not restart web server:

    Please fix error(s) in templates of Apache configuration and retry generating the configuration file.


    Although apache does not fail, it is running...

    Is there any solution/work around for that?

    Plesk 10.1.1 Centos OSx86
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Try to run

    # /usr/local/psa/admin/sbin/httpdmng --reconfigure-all

    and check error messages.
     
  3. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    No errors outputted, is there a log file to check?
     
  4. JP Kelly

    JP Kelly Regular Pleskian

    28
     
    Joined:
    Jan 20, 2007
    Messages:
    168
    Likes Received:
    0
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  5. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    Hi all,
    I have the same problem in plesk panel 10.4.4 and show me this prompt

    and this prompt
    and when i use this command
    i got this status
    please help me.
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Did you try bootstrapper repair?
     
  7. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    hello,
    no i dont use bootstrapper repair
    i just use this command.
    how can i use this command?
     
  8. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    hi again
    this is a bootstrapper result

     
  9. Seyed AhmadS

    Seyed AhmadS Guest

    0
     
    hi
    after using ./bootstrapper.sh repair apache will be working fine bute we cannot use httpdmng --reconfigure-all and we will get the error again.

    by the way, when we are working in plesk panel we got this error :
    and some times i recive this email from the server :

     
    Last edited by a moderator: Dec 7, 2011
  10. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    There are bunch of KB articles regarding different reasons of error

    Did you try to search it there?
     
  11. onlinesolutions

    onlinesolutions Basic Pleskian

    14
    85%
    Joined:
    Apr 21, 2011
    Messages:
    35
    Likes Received:
    0
    Same Problem

    I need help please. We have the same problem. This is not how expected a simple upgrade to look like. After upgrading to 10.4.4 we get this error message. An e-mail is sent advising that templates need to be adapted. The funny thing is that we have not changed any. bootsrapper.ch repair has not brought a solution either. We wasted already 10 hours support is not answering.

    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
    PleskUtilException: '/usr/local/psa/admin/bin/apache_control_adapter' '--restart' '--restart-interval' '0' '--http-port' '80' '--https-port' '443' failed with code 255.

    stdout:
    Service /etc/init.d/apache2 failed to start
    Service /etc/init.d/apache2 failed to start


    stderr:
    Service /etc/init.d/apache2 failed to start
    Service /etc/init.d/apache2 failed to start

    file: /usr/local/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
    line: 98
    code: 0
    trace: #0 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
    #1 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
    #2 /usr/local/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('7384a88e7d87a7b...', Array, Object(Service_Agent_Log))
    #3 /usr/local/psa/admin/plib/Template/Writer/Apache.php(82): Service_Agent->commit()
    #4 /usr/local/psa/admin/plib/Template/Configuration/Applier.php(202): Template_Writer_Apache->restart()
    #5 /usr/local/psa/admin/plib/Template/Configuration/Applier.php(117): Template_Configuration_Applier->_applyConfigurationsToServiceNode(1, Array)
    #6 /usr/local/psa/admin/plib/WebServerManager/Adapter/Apache.php(125): Template_Configuration_Applier->applyConfiguration(true)
    #7 /usr/local/psa/admin/plib/WebServerManager.php(311): WebServerManager_Adapter_Apache->sync()
    #8 /usr/local/psa/admin/plib/api-common/Httpdmng.php(117): WebServerManager->sync()
    #9 /usr/local/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
    #10 {main}

    2011-12-21T00:48:31+01:00 ERR (3): Apache config (13244249010.44677900) generation failed: Can not restart web server: Service /etc/init.d/apache2 failed to start
    Service /etc/init.d/apache2 failed to start

    Can not restart web server: Service /etc/init.d/apache2 failed to start
    Service /etc/init.d/apache2 failed to start

    PleskUtilException: /usr/local/psa/admin/bin/httpdmng '--reconfigure-domains' 'abc.com' failed with message: Empty error message from utility.
    file: /usr/local/psa/admin/plib/common_func.php3
    line: 1047
    code: 0
    trace: #0 /usr/local/psa/admin/plib/common_func.php3(965): util_exec('httpdmng', Array, Array, 'msg', NULL)
    #1 /usr/local/psa/admin/plib/Os.php(17): smart_exec('httpdmng', Array, Array, 'msg')
    #2 /usr/local/psa/admin/plib/Os.php(28): Os::exec('httpdmng', Array, 'msg')
    #3 /usr/local/psa/admin/plib/api-common/Httpdmng.php(101): Os::execEx('httpdmng', Array)
    #4 /usr/local/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
    #5 {main}

    Execution failed.
    Command: httpdmng
    Arguments: Array
    (
    [0] => --reconfigure-domains
    [1] => abc.com
    )

    Details: Empty error message from utility.
     
Loading...