• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

redirection *.domain problem

isabelleR

New Pleskian
I have some subdomains configured in plesk, and everything is working just fine.

Now I need to redirect people that access to any other subdomain (except the ones configured in plesk) to a different default directory.

For example http://xxx.mydomain.com to /var/www/vhosts/mydomain.com/httpdocs/default.

Ive tried to create a wildcard, with the code listed bellow, but it only works if I paste it to the end of http.include, which is discarded after any other plesk change.

If I use the vhost.conf as suggested , I get errors, because the include line at http.include is inside the first and lead me to problems with the others subdomains.


<VirtualHost xxx:80>
ServerName mydomain.com:80
ServerAlias *.mydomain.com
DocumentRoot /var/www/vhosts/mydomain.com/httpdocs/default
CustomLog /var/www/vhosts/mydomain.com/statistics/logs/access_log plesklog
ErrorLog /var/www/vhosts/mydomain.com/statistics/logs/error_log
</VirtualHost>
Is there any other way to do this ? Am I doing something wrong ?
 
Back
Top