1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

rewrite mod problems ...

Discussion in 'Plesk for Linux - 8.x and Older' started by ibor, Apr 13, 2006.

  1. ibor

    ibor Guest


    i hope you have answers to my following problem because i dont get it to work ... :

    i just looked around how to turn on rewrite_mod form apache in plesk 7.5 reloaded :

    now i found the easy solution ... :

    just edit /etc/sysconfig/apache2

    and add "rewrite" to the mod line ...

    after that restart apache --- and it will work ... but not for me ... i have the problem now that the following rewrite commands in .htaccess file will not work :

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?domain\.com(/.*)?$ [NC]
    RewriteRule \.(gif|jpg|GIF|JPG)$ http://domain.com/sorry.gif [R,L]

    it seems they are just ignored --- but rewrite is activated now - because the internal server error is gone away and the pic will be displayed now - in localhost it will work but not on the plesk server - PLEASE HELP !

    Thank you very much !

    greetz ibor
  2. ibor

    ibor Guest

    hi i found another solution to fix my problem without rewrite but there is a 500 server error if i try to use it within a htaccess file - please tell me why it works on xampp but not on plesk 7.5.4 reloaded :

    .htaccess :
    SetEnvIfNoCase Referer "^http://www.domain.com" local_ref=1
    SetEnvIfNoCase Referer "^http://domain.com" local_ref=1
    Order Allow,Deny
    Allow from env=local_ref

    please help its important for me !

    maybe its the standard settings of plesk and you can tell me how to change them - thank you SWSoft team !

    PS: usualy i dont speak english - so excuse me for the grammatical issues ..