• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Samba after update

Thomas Wilhelmi

Regular Pleskian
Hello,

running Ubuntu 14 LTS I got an update of Samba. According to my logwatch it was with the following Versions:

python-ldb:amd64 1:1.1.16-1 => 1:1.1.16-1ubuntu0.1
python-samba:amd64 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11
samba-common-bin:amd64 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11
samba-common:all 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11
samba-dsdb-modules:amd64 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11
samba-libs:amd64 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11
samba-vfs-modules:amd64 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11
samba:amd64 2:4.1.6+dfsg-1ubuntu2.14.04.9 => 2:4.1.6+dfsg-1ubuntu2.14.04.11

After that I have a Problem with the Samba-Plesk-Tool. It is shown as active and when I try to deactivate it it says that it is already deactive. But the Screen still Shows it as active. And I can connect but have not the correct rights:

Samba.JPG

The smb.cfg is exactly the same as before the update.

What to do?

Best regards.
 
So, I tried to uninstall the Fileserver via Autoinstaller and reinstal it. During configuration I got this error when creating the user:

Fehler: FileServerUser::update() failed: FileServerManager::add_user() failed: Unable to add user: filesrvmng failed: filesrvmng: /usr/bin/smbpasswd execution failed:
Failed to open /var/lib/samba/private/secrets.tdb
filesrvmng: Error during execute '/usr/bin/smbpasswd -a -n root'

but the user was shown. I tried to Change the Password and this seems to work. I got an okay.

But when I try to start the Server I get the following error:

ERROR: PleskFatalException: FileServerManager::start() failed: Unable to start fileserver: filesrvmng failed: filesrvmng: Service /etc/init.d/smbd failed to restart
filesrvmng: Service /etc/init.d/nmbd failed to restart


Additionally, an exception has occurred while trying to report this error: PleskUserException
Unable to create FileServerManager object: Unable to start fileserver: filesrvmng failed: filesrvmng: Service /etc/init.d/smbd failed to restart
filesrvmng: Service /etc/init.d/nmbd failed to restart
(modules.fileserver.toggle.php:52)
 
Back
Top