1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

security problems or not??

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by DetlefZ, Aug 19, 2009.

  1. DetlefZ

    DetlefZ Guest

    0
     
    When I start the security-check in Plesk I get the message, that there are big security problems in the system and the hint, to look in the logfile.

    The logfile shows a lot OK, NOT FOUND and so on and closes with the entry "No warnings were found while checking the system".

    So, what does this mean??
     
  2. Nataliya Zagr

    Nataliya Zagr Regular Pleskian

    21
    87%
    Joined:
    Apr 14, 2009
    Messages:
    242
    Likes Received:
    0
    Hello,

    Probably the Rootkit Hunter found new packages versions which are not listed in it's database, that is why the message like "NOT FOUND" appears. Please, try to update the Rootkit Hunter database manually with following command:

    $PRODUCT_ROOT_D/admin/sbin/modules/watchdog/rkhunter --configfile $PRODUCT_ROOT_D/etc/modules/watchdog/rkhunter.conf --update

    Before execution of command above replace $PRODUCT_ROOT_D with /usr/local/psa or /opt/psa.
    You may get value of variable $PRODUCT_ROOT_D in file /etc/psa/psa.conf on your server.

    Please, check the following article for more information:

    http://kb.odin.com/en/1323
     
  3. DetlefZ

    DetlefZ Guest

    0
     
    Thank you for the hint, but this did not help.

    I tried the command and got 9 times "No update" for the checked files. After that I run the job again und got the same result. But I found out, that it is this job that is producing the error:

    /usr/local/psa/libexec/modules/watchdog/cp/secur-check

    And the log looks like this:

    [ Rootkit Hunter version 1.3.4 ]

    Checking rkhunter data files...
    Checking file mirrors.dat [ No update ]
    Checking file programs_bad.dat [ No update ]
    Checking file backdoorports.dat [ No update ]
    Checking file suspscan.dat [ No update ]
    Checking file i18n/cn [ No update ]
    Checking file i18n/de [ No update ]
    Checking file i18n/en [ No update ]
    Checking file i18n/zh [ No update ]
    Checking file i18n/zh.utf8 [ No update ]
    Invalid option specified: --report-mode

    So how can that "invalid option" be corrected?

    TIA, Detlef
     
  4. Michael Hess

    Michael Hess Guest

    0
     
    I am seeing this one, too.

    What is your suggestion Nataliya ?
     
  5. DetlefZ

    DetlefZ Guest

    0
     
    Das Verhältnis von Bugs zu Service ist bei Parallels offenbar umgekehrt proportional ... Schade ...
     
Loading...