1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Site Preview does not work

Discussion in 'Plesk for Windows - 8.x and Older' started by GMSoftware, Aug 28, 2004.

  1. GMSoftware

    GMSoftware Guest

    I have read several threads about site preview issues, and it seems that my system is configured correctly: I do not have a default domain assigned to the shared IP address.

    I tried accessing the site preview both on the dedicated server (Windows 2003), using localhost, or from my workstation using the IP address, in any of the following 3 formats:


    None works. I get a page showing this:
    Service unavailable

    I checked in IIS console that the default website had the virtual directories properly defined.

    Additional information found after posting the original message: my server has 2 IP addresses assigned to it. One is used for an IP-based domain created in Plesk, the other one is used for IP-shared hosting. As a result, I believe that the default website does not have an IP address available anymore. Could that be the reason of the "Service unavailable" message? If yes, how can I change settings so that the domain assigned to the dedicated IP address becomes the default domain for all domains configured on the server (the default IIS site, as well as the default site for all sites created via Plesk)?

    Thanks for any advice you can provide.

  2. moyalo

    moyalo Guest

    Did you check that both IP addresses are configured in you're TCP-IP settings ?
    Control Panel -> Network Connections -> right click on you're LAN conncetion and choose properties.
    In conncetios look for:
    Internet Protocol (TCP/IP) click on it and then click properties.
    check that the mail IP address is there,
    Click Advanced and check that both IP Addresses are listed.
    If not add them to the list.

    you might also need to check IP Headers,
    In IIS Manager, right click on the website that have problems.
    choose properties, than in the Web Site Tab. Click Advance
    Check that th Ip address and TCP Port (80) and that host header value (domian.com, www.domain.com) are set ok
    for default web site is set to default Tcp port: 80
    and host header is empty (will catch all)
  3. GMSoftware

    GMSoftware Guest

    Yes, I did check on these. I do have the IP addresses listed, and the header in IIS are correct. I am still stuck. Hopefully, somebody will be able to hep and point in the right direction.
  4. mali

    mali Guest

    Restart IIS Service from Plesk Managment Console.
    I have also recieved that error,after restart it the problem has been solved.
  5. GMSoftware

    GMSoftware Guest

    Things are fine now, after reinstalling Windows 2003 and everything else again from scratch.