1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

sites prompting for username/password

Discussion in 'Plesk for Windows - 8.x and Older' started by tealnet, Oct 27, 2004.

  1. tealnet

    tealnet Guest

    0
     
    We are using Plesk 7.02/Windows 2003/IIS6... some of the web sites on the sever such as webmail, mssql admin and some other web sites will prompt the browser for a username and password when they try to open the site. Does anyone know why this happens and how we can fix it?
     
  2. Xtrm2Matt

    Xtrm2Matt Guest

    0
     
    This is to do with folder / file permissions. You need to right click the file(s) / folder(s) and hit "Permissions", then check see if the IUSR_<PLESK NAME> is in there. Hope this helps
     
  3. tealnet

    tealnet Guest

    0
     
    I checked the file permissions too, everything was set perfectly. Checked all the user settings in IIS on the web and in the application pool. Everything looked fine... unless I missed something.

    Anyway, I got my Plesk through a reseller/provider and they were stumped so they referred it to SWsoft support who logged into my server and apparently waved their magic wand and all is well now... but no one can tell me what they did.
     
  4. alldirections

    alldirections Guest

    0
     
    We have the same problem and when it happens, we solve it by recreating the hosting account.

    It would be nice to know if someone knows a permanent solution to fix this problem.
     
  5. tealnet

    tealnet Guest

    0
     
    We even tried that, several times... it finally came down to only virtual and forwarded sites that would do that. I could setup a hosted site and it would work fine, but as soon as I would go in and change it to a standard forward... it would start asking for a username and password. Very frustrating... but it's okay now and we've been adding regular and forwarding sites and so far no problems... fingers are crossed tho.
     
  6. alldirections

    alldirections Guest

    0
     
    We ran into this problem on hosted sites, not (yet?) on redirects.
     
  7. tech

    tech Guest

    0
     
    The following steps help when sites ask for username and pasword:

    From iis select the site ,rightclick properties-->select directory security and check the anonymous user option .edit it and make sure the password for IUSR is same as ftp password for the domain else reset it .save and then check.

    It works
     
  8. BillChang

    BillChang Guest

    0
     
    Hi,
    We have solved the problem by changing the IP adress of the domain user via setup section in Plesk control panel of Admin.
     
  9. Bogdan

    Bogdan Guest

    0
     
    Hello,

    I am having the same login problems on my websites. It seems that I had some sites running under invalid credentials in IIS.



    From the looks of it, the passwords for the users IUSR_domainuser from windows are not the same as the the ones set in IIS under directory security. I tries setting the password for IUSR_domainuser in IIS the same as the one for domainuser but no luck.

    I want to know... If someone manually changed the password for the domainuser or IUSR_domainuser from Local Users and Grups and didn't change anything in Plesk, if I run Plesk reconfigurator does it fix the passwords?

    I am running Plesk 7.0.3/Windows Server 2003 sp1/IIS 6.0

    Also, I need to know if the IUSR_domainuser password is the same as for domainuser password or is it randomly generated? If it is randomly generated, is it stored anyware in the psa databse?

    As a second issue... I have the NTFS permissions all messed up in the vhosts folder for a lot of domains. If I run Plesk reconfigurator will it recreate the permissions from scratch? What happenes with the users that have permission on some folders and ar not suppose to have? Are they deleted as they should be?
     
  10. =deX=

    =deX= Guest

    0
     
    as tech said,

    Open up IIS, select what site is haveing the Issue.

    Right click, Properties.

    Click Directory Security
    Click Edit
    Retype the password as you set for that domain.


    Has fixed this problem many times in the past.
    Just wish it didnt occur to begin with.

    Happens when you change a password for a domain sometimes. IIS dosent Update the IUSR password correctly
     
  11. tealnet

    tealnet Guest

    0
     
    We finally just upgraded to 7.5 and we haven't experienced this problem any more.
     
Loading...