1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SOAP-ERROR: Parsing WSDL: Sitebuilder Virtual Host not working

Discussion in 'SiteBuilder' started by Sergio Blanco Martà n, Apr 26, 2009.

  1. Hello,

    First, i'm spanish so excuse me for my bad english ...

    I've new webserver with Plesk 9.0.1 Power Pack installed, all it's okay. But When I Want to configure Sitebuilder (4.5) from Plesk, i've the error :

    SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://sitebuilder.sanjosesistemas.net/ServiceFacade/SystemWebService.asmx?WSDL'

    The DNS sitebuilder.sanjosesistemas.net it's okay. But when I try to go at http://sitebuilder.sanjosesistemas.net only default plesk page is show.

    On sb_config file configuration all is ok configure (sb_hostname is sitebuilder.sanjosesistemas.net and sb_host_ip is the IP that corresponds to the sb_hostname). And I run /usr/local/psa/bin/sitebuilder --set http://sitebuilder.sanjosesistemas.net/ServiceFacade/ to set the correct URL (http://kb.odin.com/en/6162)

    In Plesk, my configuration of Sitebuilder it's okay (I think) :

    1. I'go to "Server" >> "SiteBuilder Support"
    2. I have 3 fields :

    a. Sitebuilder server URL = My good address http://sitebuilder.sanjosesistemas.net/SeviceFacade/
    b. Username for server = my username
    c. Administrator's password = my password

    3. When i click Ok, the error appear "SOAP-ERROR: Parsing WSDL: Couldn't load from ....."

    I can´t go to http://sitebuilder.sanjosesistemas.net/check.php because ONLY visualize the default plesk page for this subdomain. The virtual host isn´t work properly. What I can configure?

    Please help me !
    Dams
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Using configuration you have Parallels Plesk apache configuration take place for domain sitebuilder.sanjosesistemas.net but Parallels Plesk Sitebuilder apache configuration should be used instead. In this case server can not find appropriate folder SeviceFacade/ and API files for integration. So in this case you need to remove sitebuilder.sanjosesistemas.net sub-domain from Plesk (or domain if it is created as domain), after that make sure that sitebuilder.sanjosesistemas.net is resolvable (leave DNS records for it only without any hosting). Restart apache service and try to access sitebuilder.sanjosesistemas.net one more time. As soon as Sitebuilder panel is loaded integration should also work correctly. Please check it up and let me know how it goes.
     
  3. Thanks for your help Dmitriy, that worked perfectly!
     
Loading...