1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Spamassasin after 7.5.2 upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by hiccup, Feb 10, 2005.

  1. hiccup

    hiccup Guest

    0
     
    Any one else having problems with incoming email showing up blank? I read all the threads regarding norton and stuff, but it isn't that.

    I have definately confirmed that if spamassasin is turn on for a particular email address then all inbound email will be blank. As soon as I turn off spam filtering for the email account then everything works out fine.

    In the .qmail file for the email account the config. of:

    | true
    ./Maildir/

    works just fine, but as soon as spam filtering is turned on and this config. is put in place it starts to fail and give me blank emails:

    | if [ -z "$SA" ]; then export SA=1; /usr/local/psa/bin/psa-spamc -f -u user@domain.com -U /tmp/spamd_full.sock > spamcheck$$; /var/qmail/bin/qmail-local "$USER" "$HOME" "$LOCAL" "" "" "$HOST" "$SENDER" "$DEFAULT" < spamcheck$$; retval=$?; rm -f spamcheck$$; [ $retval = 0 ] && exit 99; exit $retval; fi
    | true
    ./Maildir/

    I have confirmed that all the latest of spamassasin and qmail is installed according to whats available from plesk and off the fedora core 2 downloads site.

    Anyone have a resolution to get spam filtering working again with plesk 7.5.2 or should I just wait until "they" fix it and release a 7.5.3 version.

    HELP

    hiccup
     
  2. crshjnke

    crshjnke New Pleskian

    22
    57%
    Joined:
    Feb 6, 2005
    Messages:
    14
    Likes Received:
    0
    Getting the same problem except spamd starts then dies no logs or anything. Creates the PID file then just stops.

    Feb 10 11:49:41 fookmi spamc[21298]: connect(AF_UNIX) to spamd /tmp/spamd_full.sock failed: Connection refused
     
Loading...