1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SpamAssassin does not work for individual users

Discussion in 'Plesk for Windows - 8.x and Older' started by EuroMaverick, Jun 10, 2005.

  1. EuroMaverick

    EuroMaverick Guest

    0
     
    Hello people,

    I recently purchased SpamAssassin as an add-on to our existing Plesk solution. I got an updated license key and the SpamAssassin button became available on the Plesk server control panel. So far so good.

    I select the SpamAssassin button from the Plesk server control panel and select both "server-wide settings" and "personal settings" options.

    However, when I now go to individual mailboxes, I cannot activate SpamAssassin. When I hover over the button in the mailbox setup control panel, the help page to the left tells me "Spam filtering is currently unavailable. To enable spam filtering you need to have the SpamAssassin software installed, and the support for user-level spam filtering enabled on the mail box management page."

    Now, I never installed the SpamAssassin software itself, but I suppose it has been installed during the initial Plesk setup. When I look at the services in the service management, I can see the service is running and I can stop and restart it.

    Am I wrong and need I to install extra stuff here (and is that documented somewhere), or could there be something else ?

    Regards,

    Benoit.
     
  2. sieb@

    sieb@ Guest

    0
     
    You have to enable Spamassassin for the users mailbox.

    Under the Mail button for a domain, click the email user account to change, click Mailbox, then check the "Enable Spam Filtering".

    This will create the user settings file for Spamassassin to use when Qmail runs the scanner.

    You will have to set the user settings in the Spam Filter button to either the same as the server settings or stricter if desired.

    Note: Even if the server is set to a spam level of 4, if you enable user wide settings along with server wide settings, the user settings default to 7 which will override the servers setting of 4 for that user.
     
  3. EuroMaverick

    EuroMaverick Guest

    0
     
    Thanks a lot Sieb - that did it completely.

    Kind of hidden that feature ! Do you know if there is some kind of manual that explains all this more in detail ?

    Regards,

    Benoit.
     
Loading...