1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Spamd powered to 100% and kill -9 does not work

Discussion in 'Plesk for Linux - 8.x and Older' started by graffix, Jun 10, 2005.

  1. graffix

    graffix Guest

    0
     
    Hello,

    we have massive problems with spamassassin:

    i see under top that spamd is running over 140 minutes with 99,99% of cpu.
    We stopped SA but the spamd process is still persist. kill -9 <pid> doesn´t work and spamd is killing the cpu.

    How can we delete this process without a hardware restart?

    Thanks for helps
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Try doing all the following (in order):

    /etc/init.d/spamassassin stop

    killall -9 spamd (that's a number nine)

    killall -g spamd (that's a lowercase gee letter)

    other than that, personally I'd reboot the server.
     
  3. graffix

    graffix Guest

    0
     
    Hello,

    witg -g (gee) i got invalid signal specification?

    thanks for help
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    do a 'killall --help' or 'info killall' and see what yours has as an option to kill a 'group' of processes.

    On all my RedHat boxes the -g (gee) option works.

    Or you could try repeating the killall -9 spamd (number nine) until all spamd processes are killed.

    Use ps -ax | grep 'spamd' to see how many spamd processes are running at any given time.

    Also see this thread for additional things to check once you get your server back under control: (see AtomicRocketTurtle's post)

    http://forum.plesk.com/showthread.php?threadid=24676
     
Loading...