• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

spdy parameter requires ngx_http_spdy_module

RouteXL

New Pleskian
Hi,

This message is on the home screen:

New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [emerg] the "spdy" parameter requires ngx_http_spdy_module in /etc/nginx/plesk.conf.d/ip_default/[domain.com].conf:7 nginx: configuration file /etc/nginx/nginx.conf test failed

What to do?
 
Not much of a help to solve the problem but you could always disable nginx
Code:
/usr/local/psa/admin/sbin/nginxmng -e
 
It seems that you have added "spdy" directive to some of your nginx configs.
Make "grep -R spdy /etc/nginx/" and remove this directive. Then you need to restart nginx. E.g. /etc/init.d/nginx restart
 
Did some searching around and found spdy directive in /usr/local/psa/admin/conf/templates/custom/server/nginxVhosts.php

Code:
($OPT['ssl'] ? ' ssl spdy' : '') ?>;

When I changed to:

Code:
($OPT['ssl'] ? ' ssl' : '') ?>;

the configuration files could be created and nginx restarted. The problem seems to be solved. Thank you for your help.
 
Back
Top