• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved ssl_ciphers" directive is duplicate, web server reconfiguration failed

data303

New Pleskian
Dear all

I am using Plesk v12.5.30 on ‪Ubuntu 14.04.5 LTS‬ (Hosting Service). I got recently during an automatic update the following error message:

New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [emerg] "ssl_ciphers" directive is duplicate in /etc/nginx/conf.d/ssl.conf:1 nginx: configuration file /etc/nginx/nginx.conf test failed. Detailed error descriptions were sent to you by email. Please resolve the issues and click here to generate broken configuration files once again or here to generate all configuration files.

I tried to remove one of the "ssl_ciphers" directive and started the "generate broken configuration files" but it ended in another error message:

Error: Web server reconfiguration failed: New configuration was not built.

Any idea what I should try as next?

What will happen when the configuration files get re-configured do I loose my existing domains which I configured in Plesk? Or get just the config files according my settings generated?

Thank you regards
Mark
 
Try to remove /etc/nginx/conf.d/ssl.conf file and then start

# plesk repair web
 
Back
Top