1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice


Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by xorred, May 18, 2012.

  1. xorred

    xorred Guest

    I installed a SSL cert from GoDaddy on my Plesk panel yesterday - successfully - and set it up for a domain with a dedicated IP - so now when I try to access that domain by https://site.com, instead of my site, a default web page appears.

    When I go to Domains, then "view control panel", then go to the advanced field and check the checkbox "enable ssl" - and try to view https://site.com, I get the
    To my knowledge, Apache is trying to serve plain http as https and the browser freaks out.

    I've been searching 2 DAYS for a solution to this problem - all the howto documents on the net only lead you in installing the ssl cert, but not what to do to actually get it to work... your Parallels KB is .... empty on that matter as well!

    When I try to access https://ip-address, it says "this cert is for a domain, not an IP" so obviously it somehow sees the cert, it's there...

    Oh, one more thing I noticed:
    If I go to the domain / hosting settings (go to Domains, then Open in Control panel) - then in Advanced choose Enable SSL, I get the error above. If "Enable SSL" is DISABLED there, httpS://www.site.com and httpS://site.com - shows a SSL SECURED, default web page instead of my website with the correct, godaddy certificate

    Yet another edit: I just found out that there is no SSL Vhost for this ssl cert (via apachectl -S) - isn't plesk supposed to add these when you set up a ssl cert to be used for a site? if not... how do I add a ssl vhost for site.com?

    Apparently this plesk/control panel configuration is not a standard vanilla set up and just editing httpd.conf would not be a good idea... ?
    Last edited by a moderator: May 18, 2012