1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Statistics not working

Discussion in 'Plesk for Windows - 8.x and Older' started by Arkaitz, Aug 21, 2007.

  1. Arkaitz

    Arkaitz Guest

    0
     
    Hi,

    I upgraded from 8.1 to 8.2 yesterday, but now when I access the statistics page I get the following message:

    Error: Not same number of records of BrowsersSearchIDOrder (162 entries) and BrowsersHashIDLib (163 entries without msie,netscape,firefox) in Browsers database. May be you updated AWStats without updating browsers.pm file or you made changed into browsers.pm not correctly. Check your file C:\Program Files\SWsoft\Plesk\Additional\AWStats\wwwroot\cgi-bin/lib/browsers.pm is up to date.

    Statistics are also no longer updating and as stated cannot even see previous ones.

    There's a line in browsers.pm in the BrowsersHashIDLib array which I thought could be causing the problem ('svn','Subversion client'), but removing it solves nothing at all.

    I've also used the option to repair the Plesk under the Add/Remove programs because I had a problem with Apache during the whole upgrade, but that didn't solve anything either.

    Does anyone have an idea of what may be happening?

    Thanks
     
  2. Arkaitz

    Arkaitz Guest

    0
     
    Hi again,

    I've rolled from 8.2 to 8.1 but no result. From 8.1 to 8.2 again but no result either. Uninstalled AWSTATS and reinstalled it and remains the same. All of our domains have in the /statistics/webstat folder the same index.html containig the error message of the previous post.


    I've also realized the automatic statistics update is not working but if I issue the following command update works:

    perl C:\Inetpub\vhosts\domain.com\statistics\webstat\AWStats\cgi-bin\awstats.pl -config=domain.com -LogFile=C:\Inetpub\vhosts\domain.com\statistics\logs\W3SVCxxxxx\exYYMMDD.log -update


    So I guess %Plesk_Bin%\statistics.exe is not simply doing its job. Any ideas why this could be happening would be really appreciated.
    Thanks in advance
     
  3. Arkaitz

    Arkaitz Guest

    0
     
    Well I have solved the problem myself, how otherwise...
    Yesterday I run statistics.exe from command line, with no paremeters, and today everything is working fine again.
    Hope this helps somebody if in trouble.
     
  4. consultorpc

    consultorpc Guest

    0
     
    This also happened to us and simply restarting the server and running statistics.exe from command line again solved the problem.
     
Loading...