• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Strange ABRT Issue

dalydesign

Basic Pleskian
Arrived in work to find a million error emails stating that a crash has been detected:

Code:
abrt_version:   2.0.8
cmdline:        /usr/bin/python /usr/libexec/abrt-action-generate-machine-id -o /var/spool/abrt/pyhook-2016-01-18-09:53:18-16748/machineid
executable:     /usr/libexec/abrt-action-generate-machine-id
hostname:       server1.myserver.com
kernel:         2.6.32-573.12.1.el6.x86_64
last_occurrence: 1453110798
time:           Mon 18 Jan 2016 09:53:24 GMT
uid:            0

backtrace:
:abrt-action-generate-machine-id:24:<module>:ImportError: No module named argparse
:
:Traceback (most recent call last):
:  File "/usr/libexec/abrt-action-generate-machine-id", line 24, in <module>
:    from argparse import ArgumentParser
:ImportError: No module named argparse
:
:Local variables in innermost frame:
:__builtins__: <module '__builtin__' (built-in)>
:__file__: '/usr/libexec/abrt-action-generate-machine-id'
:__package__: None
:sys: <module 'sys' (built-in)>
:__name__: '__main__'
:__doc__: 'This module provides algorithms for generating Machine IDs.\n'

At the moment abrtd fails to start with the following error message:
abrtd: Failed to start: got sig 2

Also grep SELinux /var/log/messages shows:
Jan 18 10:09:47 server1.myserver.com kernel: SELinux: Initializing.
Jan 18 10:09:47 server1.myserver.com kernel: SELinux: Disabled at runtime.

Before I go digging into this, does any one have any idea what is going on?

The last auto-update was a week ago (12.5.30 Update #18, last updated at Jan 12, 2016 03:18 AM).
 
Back
Top