1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Subdomain Creation Problem - Default Plesk Page

Discussion in 'Plesk for Linux - 8.x and Older' started by Venezia, Nov 17, 2005.

  1. Venezia

    Venezia Guest

    0
     
    I am using Plesk Reloaded 7.5.4

    All subddomains for a particular domain are returning the "Default Plesk Page".

    Yes, I have waited 15mins. (Several hours now).

    The domain in question is set up as follows:

    It uses the www prefix option.
    It is on an exclusive IP.
    It uses a wildcard SSL certificate.
    It uses the shared httpdocs/httpsdocs option.

    The subdomains all have their own ftp access.

    FTP access to the subdomains works correctly.

    The only thing in vhost.conf is safemode and globals flags.

    I have tried setting up several subdomains but no joy.

    There are no manual additions to the DNS record for the domain - plesk generated only.

    I have tried restarting the webserver & bind services from the CP.

    I have restarted httpd & websrvmng from the shell command line.

    The main domain is working fine.

    Can anyone shed any light on this one?

    Thx.
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    All of that is good information, but you did not mention if you uploaded any index.html index.php or whatever to each subdomain's httpdocs folder...

    You may also want to check the main domain's httpd.include file to make sure it has been modified with Directory sections for each subdomain, such as:

    <Directory /home/httpd/vhosts/maindomain.com/subdomains/subdomnamehere/httpdocs>
    #some
    #other
    #stuff
    </Directory>

    Also make sure there is a wildcard DNS entry for the main domain.
     
  3. Venezia

    Venezia Guest

    0
     
    Thx ShadowMan for responding.

    All subdomains have:
    - the default index.html file.
    - an uploaded index.php file.
    - configured to run PHP

    httpd.include for main domain appears correct. All directory entries there.



    DNS:
    Plesk has correctly added an A record for each of the subdomains.

    I tried manually adding a wildcard record. Tried both A and CNAME. Did a restart with /usr/local/psa/admin/sbin/websrvmng -a -v but still not working.

    Have removed the wildcard record. (plesks orignal A records for the each subdomain are still in the DNS record)
     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    If you have both an index.html and index.php, the default index.html will be served up to all requests.

    This happens regardless of the apache DirectoryIndex directive's order of files. This is not just happening on Plesk servers, but with many servers running Apache 2.0

    You only want a single index.xxxx file in each httpdoc directory.
     
  5. Venezia

    Venezia Guest

    0
     
    We find that with php enabled the server serves up index.php in preference to index.html. As a bit of housekeeping we keep index.html in there just in case anything odd happens.

    But to help solve this problem we now have one subdomain with index.php and one with index.html only.

    But both of the subdomains still return


    "This is the Pleskâ„¢ default page

    If you see this page it means:

    1) hosting for this domain is not ..." etc
     
  6. ShadowMan@

    ShadowMan@ Guest

    0
     
    The only other thing offhand I can think of is to check the domain's httpd.include file for the <VirtualHost > section for the subdomain, it should look something like:
    Code:
    <VirtualHost ip.add.re.ss:80>
    	ServerName   subdomname.maindomain.com:80
    	SuexecUserGroup         domainftpuser psacln
    	ServerAdmin  "admin@maindomain.com"
    	DocumentRoot /home/httpd/vhosts/maindomain.com/subdomains/subdomname/httpdocs
    	CustomLog  /home/httpd/vhosts/maindomain.com/statistics/logs/access_log plesklog
    	ErrorLog   /home/httpd/vhosts/maindomain.com/statistics/logs/error_log
    	ScriptAlias  /cgi-bin/ /home/httpd/vhosts/maindomain.com/subdomains/subdomname/cgi-bin/
    	<IfModule mod_ssl.c>
    		SSLEngine off
    	</IfModule>
    	<Directory  /home/httpd/vhosts/maindomain.com/subdomains/subdomname/httpdocs>
    	<IfModule mod_perl.c>
    	<Files ~ (\.pl$)>
    		SetHandler perl-script
    		PerlHandler ModPerl::Registry
    		Options ExecCGI
    		allow from all
    		PerlSendHeader On
    	</Files>
    	</IfModule>
    	<IfModule mod_perl.c>
    	<Files ~ (\.asp$)>
    		SetHandler perl-script
    		PerlHandler Apache::ASP
    		PerlSetVar Global /tmp
    	</Files>
    	</IfModule>
    	<IfModule sapi_apache2.c>
    		php_admin_flag engine on
    		php_admin_value open_basedir "/home/httpd/vhosts/maindomain.com/subdomains/subdomname/httpdocs:/tmp"
    	</IfModule>
    	<IfModule mod_python.c>
    	<Files ~ (\.py$)>
    		SetHandler python-program
    		PythonHandler	mod_python.cgihandler
    	</Files>
    	</IfModule>
    		Options +Includes +ExecCGI
    	</Directory>
    	Alias "/error_docs" "/home/httpd/vhosts/maindomain.com/error_docs"
    	ErrorDocument 400 /error_docs/bad_request.html
    	ErrorDocument 401 /error_docs/unauthorized.html
    	ErrorDocument 403 /error_docs/forbidden.html
    	ErrorDocument 404 /error_docs/not_found.html
    	ErrorDocument 500 /error_docs/internal_server_error.html
    	Include /home/httpd/vhosts/maindomain.com/subdomains/subdomname/conf/vhost.conf
    </VirtualHost>
    Interesting, we tried that before and still was served the .html file, there have been a number of other posts about this here and on other non-plesk support forums also... I guess we'll have to do re-testing... :)

    A side note about websrvmng utility parameters... You didn't post the exact command you used, but we and other forum members have seen instances where the parameters which Plesk says to use (-a -v) do not work, and have had best luck with the following:

    /usr/local/psa/admin/bin/websrvmng -u --vhost-name=maindomain.com
     
  7. Venezia

    Venezia Guest

    0
     
    httpd.include looks ok.

    We've been using the -a -v options for restarts without any problems.

    Tried the domain specific options (which I'm sure is a neater way to do a restart anyway) and some of the problems have gone away.

    All the test subdomains (several created to try and iron out this problem) have started serving up correctly.

    All but one. This particular subdomain was previously hosted on this server as a full plesk domain sub.domain.com with www option. It was hosted on an exclusive IP because it used its own SSL certificate.

    The original full plesk domain & certificate have been removed from the server before we tried testing this.

    Could it be a DNS issue either on our server, or elsewhere relating to exclusive IP?

    Will delete the offending plesk subdomain from the main domain and leave it for 24hours to see if it clears up (still thinking DNS).

    I deleted the plesk subdomain from the main domain, and even after webserver restarts the offending subdomain address still brings us to the Default Plesk Page. Something somewhere is pointing to it.

    Thanks for your help Shadowman.
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Now that you have removed the 'offending' domain/subdomain, check all Apache config files (global and domain) for any remaining traces of the name. Since it was originally created as a full domain, there may still be some traces left somewhere.

    Don't forget to check the main domain's vhost.conf and vhost_ssl.conf as well.

    Now that it is no longer a real domain, make sure no A or CNAME records still exist for it.

    I've sent ShadowMan to do some real work, getting me coffee ;)
     
  9. Venezia

    Venezia Guest

    0
     
    I checked the config files - no remaining trace. Also checked the vhost & vhost_ssl.conf files of teh main domain. All clear.

    So after having deleted the domain/subdomain I let the server be for 12hours - checking periodically.

    After just over 12 hours the problem has gone - the subdomain is now unreachable.

    Weird.

    Thanks again guys for the help.
     
  10. ShadowMan@

    ShadowMan@ Guest

    0
     
    That would just be normal DNS propagation delay... nothing to worry about...
     
Loading...