1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Subdomain Problems

Discussion in 'Plesk for Linux - 8.x and Older' started by valardesign.com, Sep 30, 2008.

  1. valardesign.com

    valardesign.com Guest

    0
     
    I'm trying to create a subdomain through plesk 8.6, but for some reason the subdomain exists in plesk but not in the real world, and this is very frustrating.

    Let's say I have domain.com, now I want sub1.domain.com. According to plesk this was created successfully, now to my knowledge if I click on the open in browser link, or even if I type in sub1.domain.com in a browser I get a server not found error, or like firefox states, Address not found.

    I don't know what I should try to do to resolve this issue, tried changing dns setting as well as checking the httpd.include in /var/www/vhosts/domain.com/conf (or something like that) and everything seems fine except it doesn't want to show what the problem is :(

    Any ideas for what I should try and do?
     
  2. Maxmk

    Maxmk Guest

    0
     
    Hello,

    Might be that the while creating sub-domain due to some problems sub-domain created only in plesk database not on physical disk. Try to delete and re-add it.
     
  3. valardesign.com

    valardesign.com Guest

    0
     
    I've tried that as well, rebooted apache as well as the server itself... still nothing :(
     
  4. ziba@

    ziba@ Guest

    0
     
    Hi,

    "Address not found" error in browser means 1 thing: your subdomain does not resolve to IP address.
    Check the following:

    1. Check if subdomain resolves:
    host SUBDOMAIN_NAME

    2. If not then check if dns records for subdomain are present in Plesk:
    Domains > domain name > DNS settings

    3. Check what name servers are responsible for this domain:
    dig +trace SUBDOMAIN_NAME

    The last reply will come from name server. If NS server is not Plesk that would mean that you are using thrid party name servers and you should add necessary records to them manually.
     
  5. PieroE

    PieroE Guest

    0
     
    Similar problem

    Similar problem.
    These are the results of the commands above:

    1. Host s01.turkishny.com not found: 3(NXDOMAIN)

    2. DNS record exists. It's A-type record and has same IP as main domain (turkishny.com) - 174.132.57.60.
    Also appropriate folder for subdomain is created.

    3. dig +trace s01.turkishny.com gives me this last info: turkishny.com. 3600 IN SOA ns1.theplanet.com. support.turkishny.com. 2010100600 86400 7200 3600000 3600;; Received 93 bytes from 207.218.247.135#53(ns1.theplanet.com) in 0 ms

    I guess as the IP addresses are different ( 207.218.247.135 != 174.132.57.60 ) it means that we are using thrid party name servers. If so, where do I add those records manually?

    Any help is appreciated.
     
Loading...