1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SVN Subdomain not working, looks for directories in error_docs

Discussion in 'Plesk 11.x for Linux' started by TravisSP, Aug 22, 2012.

  1. TravisSP

    TravisSP Guest

    0
     
    Hello, I'm running into a problem serving SVN repositories from a Subdomain created by PLESK 11. I created a subdomain svn2 and followed the same instructions posted for PLESK+SVN everywhere. My vhost.conf looks like:

    <location />
    DAV svn
    SVNParentPath /var/www/vhosts/poooblic.com/subdomains/svn2
    SVNListParentPath on

    AuthType Basic
    AuthName "svn2.poooblic.com"
    AuthUserFile /var/www/vhosts/poooblic.com/subdomains/svn2/conf/passwd
    Require valid-user
    </location>

    While I could view my repositories in the browser and check them out, I ran into problems committing it:

    (20014)Internal error: Can't open file '/var/www/vhosts/poooblic.com/subdomains/svn2/error_docs/format': No such file or directory

    I don't know why it would be looking for the repositories /format in ./error_docs/. I created a Sym Link in error_docs to ./svn2/project.com and the error changed to:

    Internal error: Can't open file '/var/www/vhosts/poooblic.com/subdomains/svn2/error_docs/db': No such file or directory

    If I create a directory repos/ and move my repositories there. Then it works and no longer looks for things in error_docs.

    So it looks like this is a case of an Apache or Plesk configuration that is serving the subdirectory as a webpage when I want it to serve it as SVN Repositories. Is there a possible work around in Plesk?
     
  2. TravisSP

    TravisSP Guest

    0
     
    Just following up on my question. The gola was to have a url like svn.pooobulic.com and have a list of repositories. I couldn't find a configuration that worked for SVNParentPath. I kept the above configuration of created a subdirectory repos/ and just have to live with svn2.poooblic.com/repos.
     
Loading...