1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Trend Micro RBL+ Service causes QMail service to fail?

Discussion in 'Plesk for Linux - 8.x and Older' started by VyReN, Jan 10, 2007.

  1. VyReN

    VyReN Guest

    0
     
    Greetings,

    After upgrading to 8.1, the MAPS info has been changed to "Enable support for Trend Micro RBL+ Service". Ever since, if I enable my usual MAPS server, under "Service Management" it shows the QMail service as not running...even though it is running. ("tail"ed the log, things are moving)

    Is this a bug, or is Plesk only allowing use of the commercial service now?

    Anyone else have this issue, or am I totally unique? Like with my Spam Assassin problem...

    Thanks,
    Glen
     
  2. cjharman

    cjharman Guest

    0
     
    I have the exact same problem... I disable MAPS in the plesk control panel and the Qmail service shows that it is now running
     
  3. VyReN

    VyReN Guest

    0
     
    Heh. I fixed it.

    You can only have one MAPS server listed. Put in more than one, tis broke.

    I also upgraded to spam assassin 3.1.7 after things looked good. Figure it couldn't hurt!
     
  4. Seashore-LTD

    Seashore-LTD Guest

    0
     
    Check your MAPS Zones, if you've dead or very slow servers listed QMail/MAPS will not work. (e.g. relays.ordb.org is dead)

    This was the problem on my boxes.

    I use these blacklist servers without problems yet:

    sbl-xbl.spamhaus.org
    combined.njabl.org
    dnsbl.sorbs.net
    bl.spamcop.net
    multi.surbl.org
     
  5. VyReN

    VyReN Guest

    0
     
    How do you separate those in the textbox? If I add a ";" between servers (As I though was the SOP) the service fails according to the Service Manager.

    -Glen
     
  6. Seashore-LTD

    Seashore-LTD Guest

    0
     
    I've separeted with ; but be sure you've installed the current hotfix.
    If not follow these instructions here
     
  7. VyReN

    VyReN Guest

    0
     
    Well I'll be.

    So I suppose it doesn't matter what Plesk reports for MAPS info, it is what I write into the smtp_psa file...correct?

    Its working well now. Thanks for the help! I'm wondering if this is not an error, but a ploy to force us to use Trend Micro's service.

    Now...if I could only tackle that OTHER problem. :)

    -Glen
     
  8. keysmcplay

    keysmcplay Guest

    0
     
    Trend Mirco RBL+ doesn't seem to work with Plesk 8.1

    I'm just learning about this, but unable to get the Trend Micro Service working. It doesn't break qmail, it just doesn't bounce messages the way it should.

    I received some valuable information from someone at Trend Micro...

    Plesk seems to use it's own setup when it installs qmail/rblsmtpd.
    Normally, all you have to do is recompile rblsmtpd with the A-record
    patch and then edit the run file to give an error message after the zone
    name.

    Example run file for qmail/rblsmtpd:

    /var/qmail/supervise/qmail-smtpd# cat run
    #!/bin/sh
    QMAILDUID=`id -u qmaild`
    NOFILESGID=`id -g qmaild`
    MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
    exec /usr/local/bin/softlimit -m 4000000 \
    /usr/local/bin/tcpserver -v -R -H -l 0 -x /etc/tcp.smtp.cdb -c
    "$MAXSMTPD" \
    -u "$QMAILDUID" -g "$NOFILESGID" 0 smtp /usr/local/bin/rblsmtpd \
    -b -r "activationcode.r.mail-abuse.com:blocked using Trend Micro RBL+
    see http://www.mail-abuse.com/cgi-bin/lookup?ip_address=%IP%" \
    /var/qmail/bin/qmail-smtpd 2>&1


    But, Plesk uses it's own type of configuration files and we just have
    not been able to find a way to force Plesk to force rblsmtpd to make the
    A record lookups. It keeps looking for TXT records and it doesn't
    reject any email.


    It looks like I can use some of the free DNS Blacklist Providers, so that's the method I'll probably use. Just strange that Plesk would title the checkbox "Enable support for Trend Micro RBL+ Service" when it doesn't even work.
     
  9. VyReN

    VyReN Guest

    0
     
    Re: Trend Mirco RBL+ doesn't seem to work with Plesk 8.1

    Welcome to Plesk.
     
  10. green

    green Guest

    0
     
    Re: Trend Mirco RBL+ doesn't seem to work with Plesk 8.1

    Yeah, we've got the same problem. I've been speaking to our account manager and it's apparently due to be fixed in Plesk 8.1.1, but he can't give me any indication yet of when that's due.
     
  11. froggy

    froggy Guest

    0
     
    Hi

    I have the same problem.
    this is the answer of Trend Micro:

    We still have not seen Plesk for unix work with our service for a long time. The qmail/rblsmtpd configuration that Plesk for unix uses is looking for TXT records and it needs to be configured to look for A records. We have not found a way to make it lookup A records.
     
  12. kuhle

    kuhle Guest

    0
     
    I know this is an old thread, but I do hope that some of the contributors will be able to help.

    For a long time, we have had Trend Micro RBL+ Service enabled with sbl.spamhaus.org as the DNS zone. It worked fine, but recently it has caused outgoing messages to take approx 30-60 secs to connect/send.

    Plesk said
    It could be that we went over the allocation, http://www.spamhaus.org/organization/dnsblusage.html but I would be very surprised if we did.

    We tried replacing it with dnsbl.sorbs.net and also bl.spamcop.net but for customers who have a dynamic IP address, this prevented them from being able to send. Therefore, for now we have had to disable it.

    Does someone out there have any more information on "best practice" and some recommendations on what I should do to make it better to get rid of Spam?

    Incidentally, we do have greylisting and SpamAssassin on the servers as well, but there are a couple of Spam "threads" which get passed like software offers, geocities links, strange one-word Subjects which get through the various Spam levels.

    I look forward to hearing from some of you.
     
  13. Seashore-LTD

    Seashore-LTD Guest

    0
     
    Using smtp over SSL port 465 solve this problem.

    You can also use zen.spamhaus.org
     
  14. DmitryT

    DmitryT Guest

    0
     
    This issue is caused by incorrect DNBSL zones resolving. So, you need to make sure that your RBL/DNBSL zones can be resolved properly before putting them into "Protection" field. If they cannot be resolved - Qmail is showing as non-available in Server > Service Management (in spite of the fact that it is still up and running). Once you have all of the zones resolved properly Qmail starts showing correct status.
     
Loading...