1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Ubuntu & Plesk can't use 8443 anymore, can't fix openssl, can't upgrade

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Goranp, Nov 17, 2010.

  1. Goranp

    Goranp Guest

    0
     
    Plesk Panel 9.2.3, Ubuntu 8.04 LTS, x86

    Hi, until today everything was fine with Plesk.

    Today I couldn't open myserver:8443

    /var/log/sw-cp-server/error_log says:
    ...
    network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
    ...

    I found kb update, fix for most distros, but not for debian.

    I found some solution to modify /etc/sw-cp-server/applications.d/plesk.conf and add line which should fix the problem, but still nothing.

    OK I'll upgrade Plesk to newer version.

    Autoinstaller first error:
    Downloading the file PSA_9.5.3/plesk_getkeyinfo.sh: 48%..100% done.
    XMLRPC remote call failed: HTTP error #-1 occurred
    Error: Failed to connect to the licensing server.

    Canceled upgrade.

    Found /psa/PSA_9.2.2/plesk_getkeyinfo.sh (in folder PSA_9.2.3 didn't have that script):
    Result: PHP Fatal error: Call to undefined function iskeyprop() in Command line code on line 1

    After a lot of googling and reading this forum, decided to do autoinstaller again, even autoinstaller can't connect to licesing server, hoping upgraded Plesk will get new or normally use current key. Selected 9.5.3. version.

    Failure:
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    ERROR: autoinstaller: Error in execution of DEBIAN_FRONTEND=noninteractive
    .
    .
    .
    ERROR: Unable to install packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Not all packages were installed.
    Please, contact product technical support.

    Now when I try apt-get apt-get upgrade I have:
    libpam-plesk: Depends: psa-9.5.3 but it is not installable
    psa-backup-manager: Depends: psa-9.5.3 but it is not installable
    Depends: psa-api-rpc (= 9.5.3-ubuntu8.04.build95101022.03) but 9.2.3-ubuntu8.04.build92091009.18 is installed
    psa-miva: Depends: psa-9.5.3 but it is not installable
    E: Unmet dependencies. Try using -f.

    -------------------------------------------------------------------------------------------------------------------------------

    So now I can't manage anything through 8443 port, OK, I could workaround but my clients will not, so I need it to work.

    If i try apt-get upgrade -f - i read that mostly ended with nothing working (currently everything is working here - www, mail but 8443 port.). I'm afraid of even rebooting server or restarting psa, because it might not work...

    So what to do, please help!

    Regarding licence i pay every month server price + extra $$$ for Plesk, so Licence shout be OK.
     
  2. Leuviah

    Leuviah Guest

    0
     
  3. Goranp

    Goranp Guest

    0
     
    As I have already mentioned...
     
  4. Leuviah

    Leuviah Guest

    0
     
  5. ghostUE25

    ghostUE25 Guest

    0
     
    I´ve exactly the same problem.
    Ubuntu 8.04
    openssl 0.9.8g-4ubuntu3.12
    Plesk 9.2.3

    The problem is also described in the knowledgebase: http://kb.odin.com/en/8338
    For RPM based Systems there exists an workaround, but not for debian based systems.

    Does somebody has an idea how to solve the problem without upgrading plesk?
     
  6. ghostUE25

    ghostUE25 Guest

    0
     
    When I run the autoinstaller with the command

    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components

    I get the information that I have the newest version installed.
     
  7. SashaN

    SashaN Guest

    0
     
    solved this

    By upgrade to 9.3.0 version (no need for new license)
     
Loading...